Mailinglist Archive: opensuse-m17n (27 mails)

< Previous Next >
Re: [opensuse-m17n] IM-related issues on openSUSE 12.1 Beta
At Mon, 24 Oct 2011 20:51:36 +0900,
Fuminobu TAKEYAMA wrote:

I installed 12.1 RC1.

SCIM works fine with applications except for ones using GTK3.

Yeah, I don't get any reaction from upstream, so we are stuck.

Uim has still strange behavior on GTK3.
I also tried to launch uim-toolbar-gtk3-systray by using xdg-autostart
but it seems that the toolbar now just exits. (no zombie process!)

In my tests, it may show a single icon in the toolbar, and doesn't show
all icons. Also, the icon doesn't react. So, in practice, it's useless.
This must be a bug of UIM, after all.

For IBus, I encountered "No engine is available" problem.
When I installed RC1, I set the system language to "en" to test this bug:

After that, I change the language to "ja" and install IBus with "zypper
Then, when I started IBus, no input engines are registered.

I know I can fix just by running ibus-setup and selecting an IM engine.
However it is difficult for beginners to find out what happens since
IBus say nothing.

I have not figured out the condition in which this problem is caused.

For 12.1, we should announce to users "Please check ibus-setup when IM
is unavailable."

Or, just set up from IBUS config GUI. It's pretty intuitive.

We will be able to register a default IM engine when no engines are
Fedora has a (too) giant patch named "ibus-530711-preload-sys.patch":

Argh, that should be a thing to be either upstreamed or simplified...

I think we can implement similar behavior in xim.d/ibus.

Yes, something we should do.




(2011/10/18 0:33), Takashi Iwai wrote:
At Fri, 14 Oct 2011 18:46:43 +0200,
Takashi Iwai wrote:

At Sat, 15 Oct 2011 01:33:39 +0900,
Fuminobu TAKEYAMA wrote:

Thank you for many patches.

> test -n "$toolbar"&& (sleep 3; $toolbar&)&
When I had tried this 2 or 3 days ago, the toolbar did not work.

Now I noticed that the machine needs 15 sec. to launch GNOME3!!

The machine is HP Compaq 6710b (Core 2 Duo T7500) and not very slow.
# This is Novell Japan's machine for demo.

So, we have to set the wait to 15, 20 or more?

information from upstream's Bugzilla:
# I wonder why the toolbar works in the second log-in.

> A sane way would be to start via XDG start desktop, but it needs a
> fundamental rewrite of the basic setup.

We need IM launcher (manager) for 12.2 or later?

Yes, it's likely a better way to go.
It can be pretty simple, even a shell script.

The xim.d mechanism can (should) be still used to set the initial
environment variables or starting a daemon that doesn't need the
upper layer. The xim.d script can set a certain env variable, e.g.
$USED_INPUT_METHOD, when the IM is chosen and set up. It will contain
the IM name such as "ibus" or "scim-bridge". Then the launcher
invokes another program according to this variable, when necessary.

For example, create a script /etc/X11/xim.d/uim-launcher, which starts
the systray stuff. Then the generic launcher would execute it

test -z "$USED_INPUT_METHOD"&& exit 0
test -x /etc/X11/xim.d/${USED_INPUT_METHOD}-launcher&& \
exec /etc/X11/xim.d/${USED_INPUT_METHOD}-launcher
exit 0

and put a desktopfile in XDG-compliant autostart path.

I experimented this for uim, but it doesn't work either.
Something odd must be present in either uim or GNOME3 panel

That being said, it isn't so urgent to switch to the new startup
framework for 12.1 :)


To unsubscribe, e-mail: opensuse-m17n+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-m17n+owner@xxxxxxxxxxxx

To unsubscribe, e-mail: opensuse-m17n+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-m17n+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups