Mailinglist Archive: opensuse-m17n (69 mails)

< Previous Next >
UTF-8 LaTeX and Chinese with GNU Emacs
  • From: Friedrich Dimmling <f.dimmling@xxxxxxxx>
  • Date: Wed, 15 May 2002 17:34:46 +0000 (UTC)
  • Message-id: <200205151737.g4FHb7K04027@xxxxxxxxxxx>
Hello,

I tried to use mule-ucs with GNU Emacs from SuSE 8.0 (21.1.1) to prepare a
LaTeX file containing Chinese (simplified, mule input mode chinese-py)
characters together with German umlaut characters, using the ucs.sty.

Everything seems to work fine. However when I load the .tex file (containing
the -*- coding utf-8 -*- line) a second time into GNU Emcacs, part of the
characters is taken from the jiantizi font (rather bold face), part of the
characters is taken from the fantizi font (rather slim chars) and some
characters are just empty boxes, as if there is no available font for these
characters. I have the ifntchia.rpm installed.
A translation by LaTeX still gives correct results. Did I miss something?

BTW: The cjk-enc.el from CJK 4.4.0 which allowed to use Chinese characters
without any CJK commands in LaTeX files seems to fail with the Emacs 21.1.1.
It correctly processes the Chinese characters but skips the German umlaut
characters. It worked well with the Emacs 20.7.1 from SuSE 7.3. Is that a
known problem?

Friedrich


--
Friedrich Dimmling
Berlin, Germany

< Previous Next >