Mailinglist Archive: opensuse-kubic (68 mails)

< Previous Next >
[opensuse-kubic] Using openSUSE Kubic on a PCEngines APU2D0
Hi all,

anyone ever tried to use kubic on a PCEngines APU2?

I tried an installation via USB stick on my APU2D0 using the serial console, and
it worked.

Biggest problem was that I only had a 16GB mSATA SSD, so I got no proposal for
the partitions, but got lots of warnings regarding BTRFS and Snapshots and "Oh
my god so little space".
A larger SSD fixed that, it is now running fine on a 120GB mSATA SSD.

Bonding both NICs works.

I have configured the device using ansible, as usual. New users, settings. I
only had to tweak ansible to not use zypper when ansible_distribution is
"openSUSE MicroOS", but rather use a command calling
"/usr/sbin/transactional-update package install foo". Which of course would
required a reboot, but a handler could take care of that.

All in all a very nice experience!

Johannes
off doing something with containers on the APU2 now...

--
Johannes Kastl
Linux Consultant & Trainer
Tel.: +49 (0) 151 2372 5802
Mail: kastl@xxxxxxxxxxxxx

B1 Systems GmbH
Osterfeldstra├če 7 / 85088 Vohburg
http://www.b1-systems.de
GF: Ralph Dehner
Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537



< Previous Next >
Follow Ups