Mailinglist Archive: opensuse-kubic (24 mails)

< Previous Next >
[opensuse-kubic] New Kubic snapshot 20190909 released!
  • From: Richard Brown <rbrown@xxxxxxx>
  • Date: Thu, 12 Sep 2019 13:04:02 +0000
  • Message-id: <156829344212.32726.11592215599583095099@go-agent-stagingbot-3>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=kubic&groupid=1&version=Tumbleweed&build=20190909
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Tumbleweed&component=Kubic&query_format=advanced&resolution=---

Please do not reply to this email to report issues, rather file a bug on
bugzilla.opensuse.org.
For more information on filing bugs please see
https://en.opensuse.org/openSUSE:Submitting_bug_reports
Packages changed:
nfs-utils (2.1.1 -> 2.3.3)
pam (1.3.1 -> 1.3.1+git20190807.e31dd6c)
qrencode (4.0.0 -> 4.0.2)

=== Details ===

==== nfs-utils ====
Version update (2.1.1 -> 2.3.3)

- 0005-nfs.conf-fail-to-disable-major-NFS-version-4-using-v.patch
Fix a bug that cause NFSv4 service to always be enabled, if
the server was enabled at all.
- removal of SuSEfirewall2 service, since SuSEfirewall2 has been replaced by
firewalld, see [1].
[1]: https://lists.opensuse.org/opensuse-factory/2019-01/msg00490.html
- remove libnfsidmap1 dependency for nfs-client.
It isn't needed.
- Remove service aliases - these files are deleted.
nfs.service
nfsserver.service
nfs-server.nfsserver.conf
nfs-client.nfs.conf
Now the upstream standard service names "nfs-client" and "nfs-server"
must be used.
- 0004-nfsidmap-honour-with-pluginpath-for-instalation.patch
Allow plugins to be installed properly
- nfs-utils.spec
Package shared library correctly
- 0001-nfs.conf-allow-empty-assignments.patch
Fix regression due to unnecessary "error" messages from nfs.conf
- 0002-Let-systemd-know-when-rpc.statd-is-needed.patch
0003-systemd-run-statd-notify-even-when-nfs-client-isn-t-.patch
Fixes for systemd integration
(bsc#1116221)
- New version: nfs-utils-2.3.3
The nfsidmap library source has been merged into
nfs-utils, so this source package now makes
nfsidmap and nfsidmap-devel packages.
New program "nfsconf" improves access to nfs config files.
Delete patches that have been included upstream:
0001-conffile-ignore-empty-environment-variables.patch
0002-mount-call-setgroups-before-setuid.patch
0003-nfs-server-generator-handle-noauto-mounts-correctly.patch
nsm-headers.patch
sysmacros.patch

==== pam ====
Version update (1.3.1 -> 1.3.1+git20190807.e31dd6c)

- Replace old $RPM_* shell vars by macros.
- Avoid unnecessary invocation of subshells.
- Shorten recipe for constructing securetty contents on s390.
- usr-etc-support.patch: Add support for /usr/etc/pam.d
- encryption_method_nis.diff: obsolete, NIS clients shouldn't
require DES anymore.
- etc.environment: removed, the sources contain the same
- Update to version 1.3.1+git20190807.e31dd6c:
* pam_tty_audit: Manual page clarification about password logging
* pam_get_authtok_verify: Avoid duplicate password verification
* Mention that ./autogen.sh is needeed to be run if you check out the sources
from git
* pam_unix: Correct MAXPASS define name in the previous two commits.
* Restrict password length when changing password
* Trim password at PAM_MAX_RESP_SIZE chars
* pam_succeed_if: Request user data only when needed
* pam_tally2: Remove unnecessary fsync()
* Fixed a grammer mistake
* Fix documentation for pam_wheel
* Fix a typo in the documentation
* pam_lastlog: Improve silent option documentation
* pam_lastlog: Respect PAM_SILENT flag
* Fix regressions from the last commits.
* Replace strndupa with strncpy
* build: ignore pam_lastlog when logwtmp is not available.
* build: ignore pam_rhosts if neither ruserok nor ruserok_af is available.
* pam_motd: Cleanup the code and avoid unnecessary logging
* pam_lastlog: Limit lastlog file use by LASTLOG_UID_MAX option in login.defs.
* Move the duplicated search_key function to pam_modutil.
* pam_unix: Use pam_syslog instead of helper_log_err.
* pam_unix: Report unusable hashes found by checksalt to syslog.
* Revert "pam_unix: Add crypt_default method, if supported."
* pam_unix: Add crypt_default method, if supported.
* Revert part of the commit 4da9febc
* pam_unix: Add support for (gost-)yescrypt hashing methods.
* pam_unix: Fix closing curly brace. (#77)
* pam_unix: Add support for crypt_checksalt, if libcrypt supports it.
* pam_unix: Prefer a gensalt function, that supports auto entropy.
* pam_motd: Fix segmentation fault when no motd_dir specified (#76)
* pam_motd: Support multiple motd paths specified, with filename overrides
(#69)
* pam_unix: Use bcrypt b-variant for computing new hashes.
* pam_tally, pam_tally2: fix grammar and spelling (#54)
* Fix grammar of messages printed via pam_prompt
* pam_stress: do not mark messages for translation
* pam_unix: remove obsolete _UNIX_AUTHTOK, _UNIX_OLD_AUTHTOK, and
_UNIX_NEW_AUTHTOK macros
* pam_unix: remove obsolete _unix_read_password prototype

==== qrencode ====
Version update (4.0.0 -> 4.0.2)

- Update to version 4.0.2
* Build script fixes. (Thanks to @mgorny)
version 4.0.1
* CMake support improved.
* New test scripts have been added.
* Some compile time warnings have been fixed.
- Refreshed qrencode-fix-installation.patch


--
To unsubscribe, e-mail: opensuse-kubic+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kubic+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages