Mailinglist Archive: opensuse-kde3 (29 mails)

< Previous Next >
Re: [opensuse-kde3] 13.1: can only safely remove usb device as root user
Mark Goldstein írta:
Hi,

On Mon, Oct 5, 2015 at 4:12 PM, Ilya Chernykh <anixxsus@xxxxxxxxx> wrote:

I wrote that this solution does not work in openSUSE 13.2.


In that case I do not know the solution, sorry.


I have to admit that I've forgotten about this stuff myself :-(.

I definitely prefer to unmount as root than to remember adding this
policy-kit rules.
But I've just checked on both 13.2 and 13.1.

In 13.1 (the display manager is kdm4) I see the icon of auto-mounted
device, when selecting "safely remove" I'm getting:
Unable to unmount "/dev/sdd1".
Reason: Not authorized to perform operation

But unmount or eject command in terminal window (non-root) work OK.

In 13.2 (the display manger is kdm3) I do not see the icon (strange?),
eject or unmount as non-root fail.

I have the USB device icon mounted on the desktop after inserting USB flash
disk.
This part works for me OK.

But if I go to "storage media" and select "safely remove" for that
device it works!

I tried safely remove
- the mounted icon on the desktop
- in media window (konqueror location: media:/)
- in sysinfo window (konqueror locatonL sysinfo:/)

I all 3 cases the resut is the same: a window titled "Error -
kio_media_mounthelper" pops up saying "Unable to unmount /dev/sdc1. Reason: not
autorized to perform operation."

I even created a brand new test user to test, it gave the same result.

I do not think display manager should be important here, though who knows.

I changed kdm4 with kdm3, it did not make a difference.

Istvan

--
To unsubscribe, e-mail: opensuse-kde3+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kde3+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups
References