Mailinglist Archive: opensuse-kde3 (21 mails)

< Previous Next >
Re: [opensuse-kde3] kde3 potential gcc47 compiler code interpretation problem resulting in kwrite/kate crash
On 05/02/2012 06:43 PM, David C. Rankin wrote:
Ilya, Dominique, All,

I have been troubleshooting a runtime issue in kde3 when built on gcc47 that
does not get caught by the compiler, but produces a crash in kwrite at runtime
when lines that wrap are encountered. This problem was not discovered until
4/25. It is being worked as
http://bugs.pearsoncomputing.net/show_bug.cgi?id=979

There are multiple backtraces and strace outputs included with the bug
report.
The crash occurs when line length in a text file causes the line to wrap
within
the editor window. This can be reproduced by opening kwrite and:

(1) pasting 1-2 words using the select buffer until the line wraps; or

(2) by opening a text file with long lines and arrowing down until the long
line
is encountered.

This is 100% reproducible on Archlinux and effects kwrite/kate/quanta+ and
text preview within konqueror file manager (anything involving katepart)

On Slackware, this is limited to kwrite. Darrell Anderson reports being able
to use kate without issue, but experiences the crash in kwrite and in
konqueror
file preview.

This may not effect openSuSE, but be aware of it and test for it in your
builds based on gcc 4.7. We are currently troubleshooting, this issue and if
you
can either confirm it in openSuSE or rule it out, that would provide another
data point.

Currently we have worked backwards building code from 4/25, 4/10, 4/03 and
4/1
sources. The problem remains in all builds. We have binaries from the 3/29
build
that work, but no confirmation of the gcc version used in the 3/29 build. I am
presently building the 3/29 sources with gcc 4.7 and if the crash occurs, that
will rule out a stray patch to the code causing the issue and will implicate
something going on with the compiler. I'll let you know when I confirm the
3/29
build.

This is a cross-post to both factory and opensuse-kde3. So check the reply
address you intend to reply to. Thanks, and I hope this doesn't affect you. If
it does, the more smart people looking at it, the sooner it gets identified
and
fixed.



Ilya, All,

I just wanted to update you. I have confirmed 100% this is a gcc 4.7 issue. I
rebuilt current sources on gcc 4.6 and this bug is not present. If I build with
gcc 4.7, then this crash occurs. Let me know if you can confirm this in your
builds. Use (1) above -- it is a 100% repeatable runtime crash.

For some reason gcc 4.7 isn't generating the same code as gcc 4.6. It may be
due to some coding std. violation that isn't flagged by the compiler during
build, or it may be due to a bug in gcc 4.7. Either way, it will have to be
solved before builds on gcc 4.7 can be released.

--
David C. Rankin, J.D.,P.E.
--
To unsubscribe, e-mail: opensuse-kde3+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kde3+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References