Mailinglist Archive: opensuse-kde (310 mails)

< Previous Next >
Re: [opensuse-kde] KR49 linked libraries
On Monday 17 Sep 2012 23:24:01 Will Stephenson wrote:
On Monday 17 Sep 2012 23:11:02 Nico Kruber wrote:
KR49 contains some links to several libraries of other packages, e.g.
llvm.
These libs are needed for some packages to build for distros offering a
too- old version of them.

They are obviously disabled for openSUSE:Factory since there the newest
version should already exist. However, imho most of these could be
disabled
for at least 12.2, too since the version there is recent-enough.

Should we disable builds there or do we really need the most recent
version? - disabling builds would reduce the number of builds if these
libs change - enabling them would maybe fix some bugs

Yes, disable them if recent enough to build. They are probably a hangover
from before 12.2 was split.

Will

ok - I'll wait until my recent changes to some broken packages are
buil+published

One question about the build:direct option (don't know what its name was
exactly) recently, aqbanking was updated to 5.0.25 (5.0.23 is in 12.2).
Despite the "BuildRequires: aqbanking-devel" in kmymoney, it wasn't rebuild
on its own and I had to manually trigger it - I'm afraid if I disable libs,
this will probably happen again.

Additionally, users using KR49 will get downgrades of the published libs to
their distro version which is not ideal but probably not avoidable anymore...


Nico
--
To unsubscribe, e-mail: opensuse-kde+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kde+owner@xxxxxxxxxxxx

< Previous Next >