Mailinglist Archive: opensuse-kde (310 mails)

< Previous Next >
[opensuse-kde] Re: Re: Apper Problem Update KDE 4.9.1
On Sun, 16 Sep 2012 07:16, Basil Chupin <blchupin@...> wrote:
On 15/09/12 23:15, Yamaban wrote:
On Sat, 15 Sep 2012 14:58, Basil Chupin <blchupin@...> wrote:
On 15/09/12 18:38, ??? Niederwimmer wrote:
Hello,

I have included KDE 4.9.1, now apper like to install Update KDE 4.8.5 :(. Is
there a way to disable this Update? so apper can do his work with critical
Updates without Errors.

The only way I was able to solve this was to disable the */update/12.2/ repository.

I'd try setting the priorities for the repos right.

Overview with "zypper lr -P", then set the right order.

e.g.
Install-Media = prio 100
repo-update = prio 99
repo-kde-49 = prio 98

See "zypper help mr", esp "-p <num>" for details.

The lower the number, the higher the 'ranking'.

-- Yamaban.

No, this does nothing to alleviate the cock-up: KDE 4.9.1 is still being "upgraded" to 4.8.5 by either zypper or online update (apper).

Now I am wondering how many genuine updates will be missed because */update repo is disabled.

BC

Huh? Well, then there are also locks.

"zypper ll" to show existing locks,
"zypper al -r [repo] 'pattern'" to add.

refer to "zypper help al" for details

here in this case it would be something like:

"zypper al -r repo-update 'kde*' 'libkde*'"

to block the updates for kde from "repo-update"
without hurting the other updates.

But to call this a 'cock-up' seems right or even understated.

-- Yamaban
--
To unsubscribe, e-mail: opensuse-kde+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-kde+owner@xxxxxxxxxxxx

< Previous Next >