Mailinglist Archive: opensuse-kde (134 mails)

< Previous Next >
Re: [suse-kde] Completely black menus in GTK applications
  • From: Stephen Boddy <stephen.boddy@xxxxxxxxxxxxxx>
  • Date: Wed, 23 Nov 2005 17:36:18 +0000
  • Message-id: <200511231736.18265.stephen.boddy@xxxxxxxxxxxxxx>
On Wednesday 23 November 2005 16:35, Lennart Börjeson wrote:
> Since upgrading to SuSE Linux 10.0 my GTK application have got menus with
> black backgrounds. Very annoying since the default font colour is black,
> too...
> I've seen this in acroread, gimp and eclipse. If I run acroread from a
> konsole and activate a menu, I get the following error on stderr:
> (acroread:5291): Gdk-WARNING **: gdk_window_set_back_pixmap(): pixmap must
> have a colormap
> I've tried various settings in the ControlCentre, under "GTK Styles and
> Fonts", but to no avail. I've removed all .gtkrc* files in my home
> directory, didn't help either.
> I googled the error, and found something releated to gtk2 2.8, but I've
> checked and the indicated patch is already applied to the SuSE gtk2
> version, 2.8.7.
> Any hints on how to resolve this?

Uninstall gtk-qt-engine. It's probably an old version from before your update.
I had the exact same problem.
Steve Boddy

< Previous Next >
Follow Ups