Mailinglist Archive: opensuse-kde (305 mails)

< Previous Next >
Re: [suse-kde] xfree 4.3 and kde 3.1 / 3.1.1 = font problems / kprinter crash (BUG ?)
  • From: "Matt T." <Matt@xxxxxxxxx>
  • Date: Sun, 23 Mar 2003 20:59:50 +0700
  • Message-id: <200303232057.25577.Matt@xxxxxxxxx>
Hi Charles,

I tried your suggestions immediately.

On Sunday 23 March 2003 11:16, Charles Philip Chan wrote:
> On March 22, 2003 09:21 pm, Charles Philip Chan wrote:
> > I have the same problem and will file a bug report at The work
> > around for now is to print to a postscript file and use use lpr to print.
> I have tested it out further, it works if you choose "Generic Unix LPD
> System" instead of CUPS in KPrinter. So use that until KPrinter is fixed
> for CUPS.
> OK, I got word from one of the developers, apparently this is a known
> problem. Hopefully it will be fixed soon. I refer you to:
> Charles

But what a pity, I get the same crash everytime.

It crashes, no matter if I
- print to a ps file
- print to a pdf file
- select "Generic Unix LPD System"

I checked the link you provided at
and I'm quite sure it is unfortunately not the same problem.

Keep in mind that I see these crashes only if I use some fonts, and not with

Also, the reverse traceback is quite different, mine does not have any
KMCupsManager, ...printer... etc. messages, but mentions fontconfig and xft.
I think it crashes even before it talks to shatever printing system I want to
use. It crashes even at previewing already.

I tried to search the bug reports for something like this, however I seem to
niot uderstnd the search logic used there.

I do not see these crashes on my notebook with XFree 4.3 and kde3.1 (from
SuSE's ftp), (also SuSE 8.1).

My only workaround now is not to use half on my fonts.

What could I try next?

Thanks, Matt T.

< Previous Next >
Follow Ups