Mailinglist Archive: opensuse-ja (15 mails)

< Previous Next >
[opensuse-ja] Re: [opensuse-ja] mozcのpython2依存性
武山です

先週末に Debian, Ubuntu メンバーともくもく会をしたときに話になって
作業を始めました。

が、実は openSUSE で使っている mozc はちょっと古く、
新しくするところから作業をする必要があることに気づきました。

# ディレクトリ構成が変わるので、パッチのパスが全部崩れる(泣

# 中に、XDG_SESSION_TYPE で renderer を無効にする余計なコミットも
# あるので、このパッチも必要


gyp は Python 3 対応のものが出ていて、
python コマンドが python3 を指すように細工をすれば大丈夫そうでした。



On 2020/01/15 21:00, Takashi Iwai wrote:
岩井です。

opensuse-m17nの方に投げようかと思ったのですが、mozcはほぼ日本語のみで
すので、こっちの方にしました。

現在Tumbleweedでpython2を除くよう努力が続いていまして、ふと日本語周り
のパッケージを覗いてみた所、mozcがクリティカルにヒットしている模様です。
zinniaの方は単純にpythonバインディグを外した状態で大丈夫なようでしたが、
残りの依存性がかなり厳しいようです。

多分武山さんへの質問になると思うのですが、mozcのpy2依存性、どうしましょ
うか?遅かれ早かれこの問題は立ち上がってくるでしょうし。

Debianパッケージを見た所、どうやらprotobufは外部の物を使ってるようで、
そこのpy2以前性は省かれてるようです。
mozc自身のpy2依存性はパッチで変更されてるようです。gypは未確認。

--
Takashi Iwai <tiwai@xxxxxxx>

--
To unsubscribe, e-mail: opensuse-ja+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ja+owner@xxxxxxxxxxxx

< Previous Next >
List Navigation
References