Mailinglist Archive: opensuse-ja (33 mails)

< Previous Next >
[opensuse-ja] Re: Leap 15.1 に関して(Java)
こんばんは,岡田と申します。

On Tue, 08 Oct 2019 22:21:29 +0900
野宮 賢 / NOMIYA Masaru <nomiya@xxxxxxxxxxxxxxxx> wrote:

R> openjdk 1.8 は openSUSE 15.1 にもあるのですが、
R> https://software.opensuse.org/package/java-1_8_0-openjdk
R> これではだめでしょうか?

はい、駄目です.

Leap 42.3 では、java-1_8_0、java-11 の何れでもコンパイル出来たので
すが、 Leap 15.1 では、java-11 でのみ、コンパイル可能です.

自信はないのですが,これはAlternativesの問題かもしれません。

Yastの「その他」に[Alternatives]という項目があります。
それを起動すると,複数選択肢のあるアプリやライブラリが一覧で出てきます。
もしも複数バージョンのJavaを入れてあるのでしたら,例えば "java"
の項目を「自動(auto)」ではなく,java-1_8_0を選択すれば,あるいはjava-1_8_0でうまくコンパイルできるかもしれません。
(その代わりに選択を手動に切り替えたのでjava11で失敗するようになるかもしれませんが。)

# と書いたものの全く自信はありません。私自身はJava11しか入れていないので。
--
To unsubscribe, e-mail: opensuse-ja+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ja+owner@xxxxxxxxxxxx

< Previous Next >