Mailinglist Archive: opensuse-ja (33 mails)

< Previous Next >
Re: [opensuse-ja] Leap 15.1 に関して(Java)
野宮です.

In the Message;

Subject : Re: [opensuse-ja] Leap 15.1 に関して(Java)
Message-ID : <20191007124312.GC41929@xxxxxxxxxxxxxxx>
Date & Time: Mon, 7 Oct 2019 21:43:12 +0900

[R] == User Ribbon <opensuse@xxxxxxxxxxxxxxx> has written:

R> On Mon, Oct 07, 2019 at 08:46:04PM +0900, 野宮 賢 / NOMIYA Masaru wrote:
R> >
R> > つまり、開発者は、コンパイル時に JAVA 1.8.0 の環境を要求しており、Leap
R> > 42.3 ではその要求どおりで、コンパイル出来ました.
R> >
R> > テストのため、Leap 15.1 でもコンパイルしようとしますと、JAVA 11 の環境
R> > を求められ、驚いて開発者の HP を調べましたが、依然、JAVA 1.8 の環境が
R> > 必要と書かれてあり、Leap 15.1では、JAVA 周りの変更が加えられた為の
R> > JAVA 環境の変更だろうと考えています.
R> >
R> > 改めて調べてみますと、どうも 15.0 から JAVA 周りが変更されたと受け止め
R> > ています.
R> >
R> > このJAVA周りの変更は、どのようなものなのでしょうか?

R> ここで言うJavaって、Oracle提供のJavaをさしているでしょうか?

スミマセン、舌足らず、でした.

ここで言う JAVA は、OPENJDK のものです.

同じ OPENJDK JAVA でも、42.3 と 15.1 では随分挙動が違うと感じています.
つまり、15.1 では、当たり前のように

libjawt.so => not found

といったことになります.

---
┏━━┓彡 野宮 賢 mail-to: nomiya @ galaxy.dti.ne.jp
┃\/彡
┗━━┛ 「私たちが今日直面している化学物質の危険性に関する疑問に対し、通常の
科学的な正確さをもって答えようとすれば、たぶんさらに数十年を要するで
あろう。」 -- J. V. Rodricks --
--
To unsubscribe, e-mail: opensuse-ja+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-ja+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups