Mailinglist Archive: opensuse-gnome (38 mails)

< Previous Next >
Re: [opensuse-gnome] Timezone settings -- still not solved?
On Fri 2014-10-31, Dimstar / Dominique Leuenberger wrote:
Thanks for the pointer...
Indeed, I see this was fixed on SLE12:
:
But this patch was never submitted to the openSUSE community and as a
result is not available in the openSUSE packages.
:
We'll probably have to find a 'smarter' way for things like that.

Ouch. That's not ideal. Agreed, there is potential for improvement.

I'll see if I can forward port that TZ patch into GNOME 3.14.

I just got the update via Factory, and it works like a charm. And
did not require a reboot or restart of GNOME, even.

Thank you very much, Dominique!

PS: I have my systems generally setup to do auto-timezone switching
(control-center/date&time) and have actually not had to change the TZ
manually for a while... even more comfort than 'just not requiring the
root password'

Yes, though I have had hotel networks where the automatic detection
did not work reliably. Probably because it was a larger hotel chain
and they were routing private IP addresses via some central locations
in a different timezone (think different timezones within the US).

Plus, when I board a plane I usually switch to the destination timezone.
Without being connected to the Internet. That one probably won't work
automatically before GNOME 4.14 when gnome-clock and gnome-itinary will
be coupled? ;-)

Gerald


PS: Below my current "GNOME 3 on SUSE Papercuts" list; several issues
(incl. the two listed at the end) have been resolved already, and I feel
things definitely are moving in the right direction.

No indication that VPN fails and why (NetworkManager, GNOME)

openSUSE: open
https://bugzilla.suse.com/show_bug.cgi?id=861712
SLE 12: open, P2/major, but no activity since 2014-06-16
https://bugzilla.suse.com/show_bug.cgi?id=882789

"Organize Desktop by Name" puts icons outside the visible screen area (two
screens)

openSUSE: open
https://bugzilla.suse.com/show_bug.cgi?id=861730
SLE 12: open, even reported twice (similarly)
https://bugzilla.suse.com/show_bug.cgi?id=882793
https://bugzilla.suse.com/show_bug.cgi?id=896682

nm-connection-editor and GNOME system status out of sync

openSUSE: open
https://bugzilla.suse.com/show_bug.cgi?id=861731
SLE 12: open
https://bugzilla.suse.com/show_bug.cgi?id=882796

"All Settings - Network" not able to remove connections, edit connections,...

openSUSE: open
https://bugzilla.suse.com/show_bug.cgi?id=861740
SLE 12: should be affected as well

"When battery power is critical" in gnome-control-center, "Power" does not
allow changes

openSUSE: https://bugzilla.suse.com/show_bug.cgi?id=861976
SLE 12: https://bugzilla.suse.com/show_bug.cgi?id=882799

ModemManager: has_system_secrets: assertion 'setting_name != NULL' failed

openSUSE: https://bugzilla.suse.com/show_bug.cgi?id=861978
SLE 12: https://bugzilla.suse.com/show_bug.cgi?id=882801

nm-connection-editor main window comes up too small.

openSUSE: open
https://bugzilla.suse.com/show_bug.cgi?id=861724
SLE 12: open
https://bugzilla.suse.com/show_bug.cgi?id=882790

======== FIXED

Regression: Setting timezone does (and should not) require root.

openSUSE: not fixed for months after SLE, upon me pinging now traction and a
report
(just fixed, now only FACTORY is still open)
https://bugzilla.suse.com/show_bug.cgi?id=904058
SLE 12: fixed
https://bugzilla.suse.com/show_bug.cgi?id=862415

gnome-clocks does not allow sorting timezones / does not sort any more

openSUSE: fixed
https://bugzilla.suse.com/show_bug.cgi?id=861982
SLE 12: fixed
https://bugzilla.suse.com/show_bug.cgi?id=882802

--
To unsubscribe, e-mail: opensuse-gnome+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-gnome+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages