Mailinglist Archive: opensuse-gnome (50 mails)

< Previous Next >
Re: [opensuse-gnome] zypper dup leftovers?
Hi,

The summary, for those not willing to read details below, is that we
still have to ship parts of the GNOME 2 stack for some apps that need
it; they're not leftovers.

Le mercredi 13 juillet 2011, à 00:14 +0200, Gerald Pfeifer a écrit :
gnome-audio-2.22.2-35.2.noarch
gnome-desktop2-2.32.1-10.2.x86_64
gnome-desktop2-lang-2.32.1-10.2.noarch

Suspicous version numbers reminding me of older GNOME releases?

gnome-audio just never got another release, and I was wondering if we
should drop it.

gnome-desktop2 is just the 2.x branch of gnome-desktop, that is kept
because some packages need the library.

gnome-js-common-0.1.2-4.2.x86_64
gnome-mag-0.16.3-8.1.x86_64
gnome-main-menu-0.9.15-15.1.x86_64

Not sure about these.

gnome-js-common is fine.
gnome-mag is now removed, but we have nothing that obsoletes it. It's
unclear what should do that. Any proposal?
gnome-main-menu is "fine": that's the right version, but we might drop
it soon if nobody ports it to GNOME 3 technologies.

gnome-media-2.91.2-1.1.x86_64
gnome-media-lang-2.91.2-1.1.noarch

Leftovers from pre-GNOME 3? Removing this also wants to remove
gnome-applets, but I guess this is okay?

That's the last release of gnome-media (with gnome-sound-recorder, which
is nice). The dependency in gnome-applets is wrong now, I'll fix it.

gnome-panel-applet-tracker-0.11.0-4.1.x86_64
gnome-pty-helper-0.28.1-2.1.x86_64

Not sure.

They're fine.

gnome-python-desktop-2.32.0-10.4.x86_64

Older GNOME release?

Python bindings for some GNOME 2 libraries. Needed for some packages.
You can try to remove it to see if you need it.

gnome-speech-0.4.25-11.1.x86_64
gnome-vfs2-2.24.4-4.2.x86_64
gnome-vfs2-32bit-2.24.4-4.2.x86_64
gnome-web-photo-0.10.2-2.1.x86_64
libgail-gnome-1.20.4-2.1.x86_64
libgnome-desktop-2-17-2.32.1-10.2.x86_64

Not sure.

gnome-speech: nothing obsoleting it. Same issue as gnome-mag. Maybe
speech-dispatcher should obsolete it.
gnome-vfs2: fine.
gnome-web-photo: fine.
libgail-gnome: fine, but you can remove it.
libgnome-desktop-2-17: see gnome-desktop2 comment above.

libgnome-2.32.1-2.2.x86_64
libgnome-32bit-2.32.1-2.2.x86_64
libgnome-lang-2.32.1-2.2.noarch
libgnome-window-settings1-2.32.1-10.2.x86_64

Older GNOME release?

libgnome: fine, there's no later release. You might not need it anymore,
though, depending on what package is installed.
libgnome-window-settings1: doesn't exist anymore, and since it's using
slpp, we don't do Obsoletes for that.

libgnomeprintui-2.18.6-6.2.x86_64
libgnomeprintui-lang-2.18.6-6.2.noarch
libgnomesu-1.0.0-336.1.x86_64
libgnomesu-lang-1.0.0-336.1.noarch
libgnomesu0-1.0.0-336.1.x86_64
libgnomeui-2.24.5-2.2.x86_64
libproxy0-gnome-32bit-0.2.3-8.6.x86_64
libxine1-gnome-vfs-1.1.19-6.5.x86_64
mozilla-xulrunner20-gnome-2.0.1-4.1.x86_64
python-gnome-2.28.1-11.2.x86_64
python-gnomecanvas-2.28.1-11.2.x86_64
python-gnomedesktop-2.32.0-10.4.x86_64
python-gnomekeyring-2.32.0-10.4.x86_64
python-gnomeprint-2.32.0-10.4.x86_64
python-gnomevfs-2.28.1-11.2.x86_64

Mixture of "not sure" and me wondering whether the 2.32 refers to
the latest GNOME 2 release?

libgnomeprintui: fine, but you can likely remove it.
libgnomesu: fine, but we want to replace it.
libgnomeui: fine, see libgnome above.
libproxy0-gnome: probably not obsoleted because of slpp rule?
libxine1-gnome-vfs: no idea
mozilla-xulrunner20-gnome: fine, I think.
python-*: same as python-gnome-desktop above.

Cheers,

Vincent

--
Les gens heureux ne sont pas pressés.
--
To unsubscribe, e-mail: opensuse-gnome+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-gnome+help@xxxxxxxxxxxx

< Previous Next >
References