Mailinglist Archive: opensuse-gnome (41 mails)

< Previous Next >
Re: [opensuse-gnome] jhbuild of 2.30 help needed (75/238) libproxy - where to get correct jsapi.h
  • From: Vincent Untz <vuntz@xxxxxxxxxxxx>
  • Date: Thu, 25 Feb 2010 13:12:16 +0100
  • Message-id: <20100225121216.GB774@xxxxxxxxx>
Le mercredi 24 février 2010, à 14:42 -0600, David C. Rankin a écrit :
Guys,

I'm trying to build 2.30 on openSuSE 11.0 (latest build from openSuSE
is the
three year old 2.22). After a crash course on dependency resolution with
jhbuild, I have made it to module 75/238 (libproxy) which relies on the
mozilla
xulrunner jsapi.h header.

Hrm, building GNOME 2.30 on openSUSE 11.0 sounds a bit optimistic, to be
honest ;-)

[...]

I suspect in this situation, I don't have the correct version of
xulrunner
installed, but I have installed 190, 191, 192 which are all the versions
available and I still get this error.

Dominique might know what's going on there.

But in this specific case, why not just install libproxy-devel and skip
it in jhbuild?

[...]

Aside from the immediate libproxy issue. If anyone knows a better way
to update
gnome on this box, or any secret for meeting all the jhbuild dependencies
before
kicking off the build, I am all ears :p

If you build the jhbuild package from Contrib against 11.0 (in the build
service), you'll get a jhbuild-recommended-deps package that will
install all the dependencies for you.

Vincent

--
Les gens heureux ne sont pas pressés.
--
To unsubscribe, e-mail: opensuse-gnome+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-gnome+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References