Mailinglist Archive: opensuse-gnome (76 mails)

< Previous Next >
[opensuse-gnome] GNOME damaged after update last Friday
  • From: Uwe Galle <uga@xxxxxxxxxxx>
  • Date: Tue, 01 Jul 2008 20:47:48 +0200
  • Message-id: <486A7BD4.9050107@xxxxxxxxxxx>
Hi,

I already posted my problem into the opensuse list but this list is perhaps not the best place for a GNOME problem. After I installed five mandatory upgrades on Friday on my openSUSE 10.3 system I got a German error message. The corresponding English message is in the thread http://lists.opensuse.org/opensuse-bugs/2007-05/msg01270.html and reads as follows:

There was an error starting the GNOME Settings Daemon.
Some things, such as themes, sounds, or background settings may not work correctly.
The last error message was:
The name org.gnome.SettingsDaemon was not provided by any .service files
GNOME will still try to restart the Settings Daemon next time you log in.

Unfortunately, this thread contains no solution. Also in the archive of the GNOME list I didn't find this message. My system might have had a problem already, but the error message came only on Friday. More details I posted into the opensuse list later but got no reply until today. Because I am a bit under pressure I repost this problem into the GNOME list now. The following is my answer today and gives you further details:


On Sat, 2008-06-28 at 12:09 +0200, Uwe Galle wrote:
I already posted a problem caused by mandatory updates, perhaps in conjunction with a specific system configuration of my computer. Now I see that the control center cannot start. Altogether I am missing two executables:
- gnome-control-center and
- gnome-settings-daemon

Thanks to search.rpmseek.com I know that these files belong to several packages. But openSUSE 10.3 provides only one of these: control-center2.

The package was renamed in 11.0.

OK. But I am still on 10.3. As long as the openSUSE Kolab site only lists 10.3 as tested OS (http://en.opensuse.org/Kolab), I don't want to upgrade. I want to use Kolab.

Surprisingly this package is displayed as to be not installed although gnome-control-center and gnome-settings-daemon always worked until yesterday. I don't know of another openSUSE-package what contains these files.

Unfortunately YaST rejects the installation of this package because it requires "libxklavier >= 3.5" for "libxklavier12-3.5-3.1.i586". In my understanding this should be a bug because no already installed package can be dependent from a new package and prevent it from being installed. Even if a new package requires a second version of an already installed package rpm should ensure that these two versions can coexist.

Then I guessed that the rpm database is perhaps damaged and started an rpm --rebuilddb. Answer: Can't create transaction lock on /var/lib/rpm/..db.00 (even after reboot!).

Now I retried rpm --rebuilddb and it worked. But the installation of control-center2 with YaST is still impossible because of a lot of complicated and unresolvable dependencies. In Smart Package Manager 0.52 I don't see this package at all.


I am desperately looking for a way to install "control center2" ...

Are you on 10.3 or 11.0?


As said above, I am on 10.3.

In the meantime I tried an Upgrade similar to that described on http://en.opensuse.org/KDE/Upgrade. But this procedure doesn't work for me.

At first I ensured that the GNOME:STABLE: repository as given in http://en.opensuse.org/GNOME/Software_Repositories is configured and activated. The only other activated repositories are - as given in http://en.opensuse.org/Package_Repositories - the main repository (http://download.opensuse.org/distribution/10.3/repo/oss) and the Non-oss repository (http://download.opensuse.org/distribution/10.3/repo/non-oss). Other repositories I don't want to activate because they are not mentioned in "Upgrading KDE on openSUSE" and may perhaps cause harm when more packages are upgraded as necessary. I refreshed all repositories.

According to "Upgrading KDE on openSUSE" I shall invoke Software Management now and select an installation source for KDE. Then I shall right-click on a package and select "Update ...". But both actions are not possible for GNOME-YaST. I cannot select an installation source so that all corresponding packages are selected and I cannot make a right-click in a package list what shows a context menu. It would be very desirable to have a similar HOWTO for GNOME as that for KDE on http://en.opensuse.org/HOWTOs.

I want to thank you for replying. I already send three postings to the opensuse list and got no reply. In my third posting I made some thoughts about making an upgrade with zypper. After rpm --rebuilddb has worked I see that "zypper if" shows for all tested packages the repository "openSUSE BuildService - GNOME:STABLE" (download.opensuse.org/repositories/GNOME:/STABLE/openSUSE_10.3/). That surprises me because I never installed GNOME components from the Build service by design.

After reading "Upgrading KDE on openSUSE" I am a bit cautious to work with zypper ("WARNING: 'zypper up -t package' will upgrade all packages from all repositories to newer versions, potentially moving you off many supported packages and onto unsupported packages.") That's why I want to restrict the active repositories as far as possible. On the other side I don't want to run into problems because of unresolved dependencies. That's why I want to run a check with zypper if all active repositories are sufficient for a GNOME update. How can I do that? The man page of zypper shows no option for such a check.

Thanks a lot.
Uwe
--
To unsubscribe, e-mail: opensuse-gnome+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-gnome+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages