Mailinglist Archive: opensuse-gnome (77 mails)

< Previous Next >
Re: [opensuse-gnome] [Fwd: [GNOME Maint.] Gnome in OBS setup]
  • From: JP Rosevear <jpr@xxxxxxxxxx>
  • Date: Wed, 18 Jun 2008 17:47:27 +0000
  • Message-id: <1213811247.29740.224.camel@xxxxxxxxxxxxxxx>
On Wed, 2008-06-18 at 19:32 +0200, Adrian Schröter wrote:

On Wednesday 18 June 2008 18:43:58 James Ogley wrote:
Then can't you get bin incompats the other way? Ie without updates.

And in fact it's more likely since the vast majority of users will be
using the update repo.

If this is the case, it does mean the developer providing the fix has ignored
our policies or did not understand the code, maintenance / project manager
has
not seen the problem and QA checking has failed all together.

I think in practice this is basically non-existent, but I disagree with
the assertion that if binary incompatible updates go into the updates
its not a problem for users on GNOME:STABLE not using updates. Largely
irrelevant though i think.

It would be really a big issue when such a thing happens. If you see such a
thing happen report it and we need to revert such an update immediatly.

On the other hand you cause only problems by using the Update repo,
especially
with large project. You cause significant more build load, more load to the
mirrors and unneeded updates for the users.
We might need to add a penalty to the gnome project for situations where we
need to release updates of base packages for all distributions (what happens
regulary).

Ok, this seems somewhat key, James, Maw?

-JP
--
JP Rosevear <jpr@xxxxxxxxxx>
Novell, Inc.

--
To unsubscribe, e-mail: opensuse-gnome+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-gnome+help@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups