Mailinglist Archive: opensuse-gnome (56 mails)

< Previous Next >
Re: [opensuse-gnome] Pidgin
  • From: "Joe Shaw" <joe@xxxxxxxxxxx>
  • Date: Thu, 3 May 2007 11:43:12 -0400
  • Message-id: <f8203010705030843q78aaf493i606d64860946649e@xxxxxxxxxxxxxx>
Hi,

On 5/3/07, JP Rosevear <jpr@xxxxxxxxxx> wrote:
On Thu, 2007-05-03 at 08:37 +0100, James Ogley wrote:
> > Sounds good to me, worst that happens is we don't move it into Factory.
>
> Is the best way to do this to add something like this to the spec file:
>
> Provides: gaim = %version-%release
> Obsoletes: gaim
>
> Or is there some spec-file-foo for saying it upgrades a differently
> named package that I'm not aware of?

Nope, that should be it.  See ekiga for an example.

It might also be a good idea to add "Conflicts: gaim < [some version]"
so that you can't also install an older version of gaim, which would
probably fail because of file conflicts at install-time.

Joe
--
To unsubscribe, e-mail: opensuse-gnome+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-gnome+help@xxxxxxxxxxxx

< Previous Next >
List Navigation