Mailinglist Archive: opensuse-fr (11 mails)

< Previous Next >
Re: [opensuse-fr] Java
  • From: Pierre Coutant <coutantp@xxxxxxx>
  • Date: Sun, 20 Jun 2010 19:32:19 +0200
  • Message-id: <4C1E50A3.4010602@xxxxxxx>
Le 19/06/2010 10:38, Bruno Friedmann a écrit :


Je réponds à la liste comme cela c'est aussi vérifier par les autres.

Bon donc si tu es en 32bits, tu peux vérifier et désintaller au besoin le
paquet nspluginwrapper
Bien, le paquet nsdiswripper était installé, je l'ai donc désinstallé. A
la suite de quoi le site de java me dit que j'ai la bonne version. On
avance... mais le site de SFR n'et toujours pas fonctionnel pour moi...
Donc tout n'est pas parfait.


ensuite vérifier quelle est ta machine virtuelle par défault
java -fullversion
actuellement avec la sun-java exclusivement java full version "1.6.0_20-b02"
C'est bien la bonne version sur ma machine.


Ensuite vérifier quels sont les restes d'openjdk
zypper se -s openjdk devrait te donner une liste ou aucun i n'est présent
dans la première colone

(le seul paquet java hormis les programmes, présent et non effaçable pour
cause de dépendances est java-1_5_0-gcj-compat )
Voici tout ce qui apparaît:
S | Nom | Type | Version |
Arch | Dépot
--+----------------------------+---------------+--------------------+--------+----------------------------------
| java-1_6_0-openjdk | paquet | 1.6.0.0_b17-2.1.1 |
i586 | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk | paquet | 1.6.0.0_b16-5.10.1 |
i586 | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk | paquet | 1.6.0.0_b16-5.9.4 |
i586 | openSUSE-11.2-Oss
| java-1_6_0-openjdk | paquet | 1.6.0.0_b16-5.9.4 |
i586 | openSUSE 11.2-0
| java-1_6_0-openjdk | paquet source | 1.6.0.0_b17-2.1.1 |
noarch | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk | paquet source | 1.6.0.0_b16-5.9.4 |
noarch | openSUSE-11.2-Source
| java-1_6_0-openjdk | correctif | 2362 |
noarch | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk | correctif | 1613 |
noarch | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-demo | paquet | 1.6.0.0_b17-2.1.1 |
noarch | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-demo | paquet | 1.6.0.0_b16-5.10.1 |
i586 | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-demo | paquet | 1.6.0.0_b16-5.9.4 |
i586 | openSUSE-11.2-Oss
| java-1_6_0-openjdk-devel | paquet | 1.6.0.0_b17-2.1.1 |
i586 | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-devel | paquet | 1.6.0.0_b16-5.10.1 |
i586 | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-devel | paquet | 1.6.0.0_b16-5.9.4 |
i586 | openSUSE-11.2-Oss
| java-1_6_0-openjdk-devel | paquet | 1.6.0.0_b16-5.9.4 |
i586 | openSUSE 11.2-0
| java-1_6_0-openjdk-javadoc | paquet | 1.6.0.0_b17-2.1.1 |
noarch | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-javadoc | paquet | 1.6.0.0_b16-5.10.1 |
i586 | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-javadoc | paquet | 1.6.0.0_b16-5.9.4 |
i586 | openSUSE-11.2-Oss
| java-1_6_0-openjdk-plugin | paquet | 1.6.0.0_b17-2.1.1 |
i586 | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-plugin | paquet | 1.6.0.0_b16-5.10.1 |
i586 | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-plugin | paquet | 1.6.0.0_b16-5.9.4 |
i586 | openSUSE-11.2-Oss
| java-1_6_0-openjdk-plugin | paquet | 1.6.0.0_b16-5.9.4 |
i586 | openSUSE 11.2-0
| java-1_6_0-openjdk-src | paquet | 1.6.0.0_b17-2.1.1 |
noarch | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-src | paquet | 1.6.0.0_b16-5.10.1 |
i586 | Mises à jour pour openSUSE 11.2-0
| java-1_6_0-openjdk-src | paquet | 1.6.0.0_b16-5.9.4 |
i586 | openSUSE-11.2-Oss
Pierre@linux-onr3:~>

Si cela doit être supprimé, comment ? Ces paquets n'apparaissent pas
dans Yast.

Un about:plugins ne parle plus de ice mais uniquement de Java.

Entretemps, j'ai voulu (et fait) une suppression et une réinstallation
de Java. Cela c'est bien déroulé mais lors de la suppression il s'est
installé "libgcj44" sans que je le demande; et apparemment sans
conséquences.

Après j'utilise souvent une recette pour remettre de l'ordre dans
/etc/alternatives

c'est update-alternatives ( en tant que root )

Voir la sortie http://www.pastebin.org/342480

Enfin, je ne sais comment utiliser (quelles options) update-alternatives.


Maintenant je ne sais pas avec l'histoire du openjdk-17 comment ça était
installé. si manuellement il faut peut-être aussi
l'effacer proprement.
Ça a été installé par yast après l'installation de la distribution.


A+



--
Pierre COUTANT

--
To unsubscribe, e-mail: opensuse-fr+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-fr+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups