Mailinglist Archive: opensuse-fr (7 mails)

< Previous Next >
[opensuse-fr] Message 'no dial tone' avec smartlink-softmodem sur SuSE 10.0
  • From: Chapot Jacques <j.chapot@xxxxxxx>
  • Date: Sat, 17 Jun 2006 20:09:04 +0200
  • Message-id: <200606172009.05178.j.chapot@xxxxxxx>
Bonjour,

Pourriez-vous me donner une aide pour faire fonctionner mon modem (SiS 7013)
sur un portable ACER Aspire 1700.

------------------------------------------------------------------------------------
Après pas mal de recherche, voici quelques informations :

J'ai remarqué que je devais désactiver l'ACPI au boot du système en rajoutant
les options sous grub : noacpi acpi=off

Commande : lspci
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev
a0)

Commande : lspci -n
00:02.6 Class 0703: 1039:7013 (rev a0)

Commande : cat /proc/version
Linux version 2.6.13-15-default....

J'ai installé le package 'smartlink-softmodem-2.9.10-17.i586.rpm' qui semble
être recommandé avec la version du noyau.

Commande : modprobe snd_intel8x0m

Commande : cat /proc/asound/cards
0 [SI7012 ]: ICH - SiS SI7012
SiS SI7012 with ACL202 at 0x1C00, irq 5
1 [modem ]: ICH-MODEM - SiS SI7013 Modem
SiS SI7013 Modem at 0x1400, irq 5

Commande : slmodemd --alsa --country=FRANCE hw:1
symbolic link '/dev/ttySL0' -> '/dev/pts/2' created.
modem 'hw:1' created. TTY is '/dev/pts/2'
Use '/dev/ttySL0' as modem device

Commande : ln -s /dev/ttySL0 /dev/modem

En utilisant le programme 'minicom -o', voici la liste des commandes AT que
j'envoie au modem :
ATZ <- Initialisation
OK
ATM1 <- Haut-parleur jusqu'à la connexion
OK
ATL3 <- Volume max
OK
ATDT0860922000 <- Appel de l'accès libre de 'free'
NO DIALTONE
------------------------------------------------------------------------------------

Pourriez-vous m'aider afin de réaliser un connexion ?

De plus, j'ai remarqué que l'on pouvez activer le mode '--alsa'
dans /etc/sysconfig/slmodemd, mais comment fait-on pour le paramètre 'hw:1' ?

J'ai remarqué que le service 'slmodemd' ne fonctionne pas si on n'a pas au
préalable chargé le module 'snd_intel8x0m'. Comment faire pour qu'il se
charge automatiquement avec le service de manière propre pour SuSE ?

Enfin, existe-t'il un moyen de conserver l'ACPI (le ventilateur est quand même
bruyant) tout en conservant le fonctionnement du modem ?

Cela fait pas mal de questions, j'espère aider cette distribution à améliorer
sa reconnaissance du matériel. Merci d'avance pour les réponses.

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-fr-unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-fr-help@xxxxxxxxxxxx

< Previous Next >
List Navigation
Follow Ups