Mailinglist Archive: opensuse-features (199 mails)

< Previous Next >
[openFATE 321752] *working* bluetooth (audio) support
Feature changed by: Tomáš Chvátal (scarabeus_iv)
Feature #321752, revision 4
Title: *working* bluetooth (audio) support

- openSUSE Distribution: Unconfirmed
+ openSUSE Distribution: Rejected by Tomáš Chvátal (scarabeus_iv)
+ reject reason: If anything this is a bug. I tried to connect couple of
+ headphones and one speaker set and all worked without a glitch on a
+ laptop and desktop with usb dongle. Thus feel free to report properly
+ descriptive bug explaining what kind of dongle you have and all the
+ other things.
Priority
Requester: Important

Requested by: Michal Suchanek (michals)
Partner organization: openSUSE.org

Description:
ok, so I tried to connect bluetooth headphones to a Leap 42.2 box. I
had bluez to start with just in case You also need the bluez pulseaudio
plugin for sound because there is no other way to get sound out of
bluetooth. 1) installing bluez-firmware does not give me firmware for
bluetooth dongle. The firmware is in bcm20702a1-firmware. Maybe bluez-
firmware should depend on that? 2) after installed the dongle is not
brought up and diagnostic tools fail. Is it so difficult to add an udev
script that does "hciconfig hci<n> up" for every chi device? 3) gnome-
control-center tells me I have no dongles after doing all this 4) Using
bluetoothctl I can now connect devices -- unless I attempted connecting
them with hcitool which puts them in some broken state. 5) when my
headphones are connected pulseaudio shows them as sink but built-in
sound card remains default sink. You can STFW for some script that
forces sink switch for running applications as well.
Totally awesome. I can expect everyone to use bluetooth audio on Linux.
So simple.

Discussion:
#1: Stakanov Schufter (stakanov) (2016-10-14 19:04:01)
I'm a bit puzzled. I come from trying a BT Headphone BT 4.0 on Leap
42.2 beta3. Unlike 42.1 where BT support for me is totally broken and
if ever only mouse support works (not even OBEX), in 42.2 I found that
at leas file transfer and BT headset audio, if conveniently set up,
works well and with the appropriate selected audio profile. Sound
quality is good and the only bug I encountered currently is, that the
BT headset is not selected in automatic when it becomes available,
although in priority set first of all devices. Are you sure that the
problem is not just a proprietary firmware blob (which then is
responsibility of the producer of the device, not of linux)? The
firmware you write about seems to be problematic in Linux tout court
with problems not only in Leap, but also Ubuntu etc.. Maybe it would be
good to have a pattern BT that forces immediately the install of the
firmware and all relevant pulseaudio-plugins etc. However it seems that
the problem is very hardware dependent. For me (happy me) the 42.2 beta
3 word nearly out of the box with all features (Beta version under KVM
and dongle not through spice but directly installed as usb hardware.)

#2: Stakanov Schufter (stakanov) (2017-03-24 08:48:13)
I do honestly not know if the fact that BT audio is not working at all
in 42.2 is a regression. In beta 1 it seemed to work finally. But also
obex is not working as it should. Now a question. 7 years(!) of a
request for a better audio bluetooth support
https://features.opensuse.org/309550 and seriously(!!!) people who
voted against? Why not filing an "enhancement" feature: take off BT
support of leap because there are not resources to handle it right?
That would be probably more honest.
Please fix BT audio and obex support in Leap or take off BT support all
together. Shipping broken software for years does not add to the
reputation of openSuse. (Tried an proven with 42.1 broken, 42.2 broken.
Independently if with broadcom BCM2045B adapter or Cambrige Silicon
Radio dongle. Pulseaudio source selection is broken. But also Obex is
unreliable. Bugs are filed and nobody cares. So maybe it is time to
just take it off?




--
openSUSE Feature:
https://features.opensuse.org/321752

< Previous Next >
This Thread
  • No further messages