Mailinglist Archive: opensuse-features (199 mails)

< Previous Next >
[openFATE 308467] Proprietary install driver HELP guide
Feature changed by: Tomáš Chvátal (scarabeus_iv)
Feature #308467, revision 10
Title: Proprietary install driver HELP guide

Hackweek V: Rejected by Karl Cheng (qantas94heavy)
reject reason: Not done.
Priority
Requester: Important

- openSUSE Distribution: New
+ openSUSE Distribution: Rejected by Tomáš Chvátal (scarabeus_iv)
+ reject reason: There is no plan to tweak this behaviour. Also amd today
+ has amdgpu that is fully integrated. For the nvidia it can't get much
+ simpler than http://opensuse-community.org/
Priority
Requester: Desirable

Requested by: Lee Matheson (oldcpu)
Partner organization: openSUSE.org

Description:
A constant criticism of openSUSE is the lack of an easy continuous
installation of proprietary graphic drivers.  Is it not possible to
post specific (and very obvious) help links to community wiki that
provides guidance as to how the proprietary graphic drivers can be
installed  (as opposed to just a general statement) ? i.e. a link for
community help page for ATI proprietary graphic drivers and a similar
one for nVidia proprietary graphic drivers.

Discussion:
#1: Jan Engelhardt (jengelh) (2010-05-06 23:15:41)
What's wrong with http://en.opensuse.org/NVIDIA_drivers ?

#2: Lee Matheson (oldcpu) (2010-05-26 11:58:06)
> What's wrong with http://en.opensuse.org/NVIDIA_drivers
(http://en.opensuse.org/NVIDIA_drivers) ?
Such guides are useful.  Thats not the point of the feature !
The idea behind the feature is to provide links in the "as packaged"
openSUSE release, perhaps in the browser bookmarks (as packaged) or in
a folder on the desktop (although I dislike the clutter of
that).  Hence maybe pre-packaged bookmarks is the best idea ?
IMHO the need for Links already in openSUSE (such that one is not
forced to surf and get many hits, some of which are excellent and some
of which are not good) is becoming even more important now, with the
dropping of sax2 and with nVidia reducing their support for "nv", where
"nouveau" driver is still not as mature as many would like.

#3: Joe D'Angelo (wolfspider2) (2010-07-18 03:53:06)
I did this and it worked for me. I un-installed the new nvidia driver
that comes with 11.3 and re-added the old 11.2 repository for nvidia. I
then picked the kernel from the list in yast and installed it. It says
there is nothing to support it and you need to ignore this waring and
break it. You will get a few other warnings as it binds the kernel. Now
you should have some choice as to what to set your resolution to. I
then went to the nvidia web site and got the NVIDIA-Linux.run file for
my card. I ran it as root as directed to. You need to have all the
development tools and the kernel source for this to work. It re-
compiled the kernel and now I can run the nvidia config app and have
the proper graphic support I need. I know this is a bit on the strange
side but I have seen no better ways to handle this so far. The openSUSE
development team seems to be a bit behind the curve on this. They
really need to start reading what we the users are saying.
 




--
openSUSE Feature:
https://features.opensuse.org/308467

< Previous Next >
This Thread
  • No further messages