Mailinglist Archive: opensuse-features (39 mails)

< Previous Next >
[New: openFATE 318395] Provide gpg-1.4
Feature added by: Neil Rickert (nrickert)

Feature #318395, revision 1
Title: Provide gpg-1.4

openSUSE Distribution: Unconfirmed
Priority
Requester: Important

Requested by: Neil Rickert (nrickert)
Partner organization: openSUSE.org

Description:
It appears that support for old pgp2 keys is being removed from gpg2. This has
already happened in Tumbleweed (factory), and will probably be in 13.3. The
gnupg developers are recommending that people use gpg-1.4 if they still need to
use those older keys. It is not currently provided by opensuse, though I notice
that it is present in a recent Mint install (so probably in ubuntu). My
personal use would be for examining my historic web-of-trust, built up over a
number of years. That web of trust depends on keys that were signed with pgp2
keys.

My suggestion would be that it be installed somewhere other than "/usr/bin" --
perhaps in "/usr/lib/gpg14". We should continue to use gpg2 for most things.
Those who need access to older keys can set a suitable path or use a shell
script to access gpg-1.4. They probably will be setting environment variables
to use a separate gpg keyring for the older keys.


--
openSUSE Feature:
https://features.opensuse.org/318395

< Previous Next >
List Navigation
This Thread
  • No further messages
Follow Ups
References