Mailinglist Archive: opensuse-features (311 mails)

< Previous Next >
[New: openFATE 311112] libvirt driver for new xen toolstack
Feature added by: James Fehlig (jfehlig)

Feature #311112, revision 1
Title: libvirt driver for new xen toolstack

Hackweek VI: Unconfirmed
Priority
Requester: Important

Requested by: James Fehlig (jfehlig)
Partner organization: openSUSE.org

Description:
Xen 4.1.0 (due February 2011) will be the first release in which the new
xl/libxl (aka libxenlight [1]) toolstack will be the default, preferred tool
set. Although still included in the release, the legacy xm/xend toolstack will
be disabled and in process of deprecation.

libvirt needs a hypervisor driver that can communicate with the new Xen
toolstack. I'll be working on a libvirt driver for libxl during HW6.

Business case (Partner benefit):
openSUSE.org: There are many tools using libvirt: vm-install, virt-manager,
virt-viewer, vhostmd, libvirt-cim, ... None of these tools will work with Xen
4.1.0 without a libvirt libxl driver.

--
openSUSE Feature:
https://features.opensuse.org/311112

< Previous Next >
List Navigation
This Thread
References