Mailinglist Archive: opensuse-factory (339 mails)

< Previous Next >
Re: [opensuse-factory] new X wrapper script (was: New Tumbleweed snaps...)
Michael Pujos composed on 2020-10-08 16:53 (UTC+0200):

After this update I could not start Xorg anymore due to the xorg/xinit
package changes

Now my setup is unusual, as I do not use a DM and just use startx
launched in ~/.profile which itself run at console login.
I'm documenting the issue I had, for reference.

With this update /usr/bin/Xorg is now a shell script running
/usr/bin/Xorg.wrap if present or /usr/bin/Xorg.bin otherwise.
previously,  /usr/bin/Xorg was /usr/bin/Xorg.bin.

I had /usr/bin/Xorg setuid root via /etc/permission.local and chkstat,
but this obviously did not work anymore since now
/usr/bin/Xorg.bin needed to be setuid root instead.

Did that and X started successfully  but exited immediately with code 0.
Investigating further, I found that /etc/X11/xinit/xinitrc had been
moved to /usr/libexec/xinit/xinitrc, and since
I had my ~/.xinitrc call /etc/X11/xinit/xinitrc, it choked on that (file
not found) and updating the path fixed it.

Next, I thought it might be a good idea to switch to Xorg.wrap found in
package xorg-x11-server-wrapper.
So I installed it, removed setuid on /usr/bin/Xorg.bin and startx worked
when logged on the console and starting it from there.
But it failed when startx was launched in  ~/.profile, during console login.
Looked at 'man Xrapper.config', created /etc/X11/Xwrapper.conf with

allowed_users=anybody

But then, no matter what, startx always failed with:

/usr/bin/Xorg.wrap: Xserver option ":0" invalid or not in whitelist.
Aborting.

Thus had to revert to the initial setuid solution.

Looks like good reason for a regression bug report. Note though that Stefan
Dirsch, who usually is responsible for X bug fixes, will usually denigrate
startx
usage and state that it is "unsupported", even though all other distros I'm
familiar with seem not to be of the same persuasion.
--
Evolution as taught in public schools, like religion,
is based on faith, not on science.

Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata *** http://fm.no-ip.com/
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups