Mailinglist Archive: opensuse-factory (266 mails)

< Previous Next >
Re: [opensuse-factory] initrd -> initramfs
On Mon, 04 May 2020 22:40:46 +0200
Takashi Iwai <tiwai@xxxxxxx> wrote:

On Mon, 04 May 2020 19:01:18 +0200,
Andrei Borzenkov wrote:

04.05.2020 14:17, Takashi Iwai пишет:
On Mon, 04 May 2020 12:37:01 +0200,
Daniel Molkentin wrote:


In an effort to get the naming right. I would like to propose renaming
the /boot/initrd-$(uname -r) images to /boot/initramfs-$(uname -r).img.

Rationale: We are not using initrd's (that is: actual block devices) for
a long time now. Instead, an initramfs is a cpio archive that gets
deflated to a tmpfs. And, this would allow me to drop some more of our
vendor patches off dracut.

I am currently collecting affected packages. So far I found:

- aaa_base (refresh_initrd script)

- YaST

- grub

- kdump

- perl-Bootloader

Anything I am missing?

The kernel-default and co who own those initrd files.

And that'll be tricky -- if we rename it, which file name to be
packaged would depend on dracut package, but dracut isn't included in
the build requirement for the kernel binary package. So we can't know
whether dracut prefers initramfs or initrd at the package build time.

Why not own both initrd and initramfs? After all, it is just a %ghost,
it need not exist.

Having both may confuse the package size calculation. You can find in
kernel-default.spec that kernel puts some (fixed) sized empty file as
a dummy initrd.

So this kind of change itches at every place in details...

Also it won't retroactively happen for existing kernels. So if new
kernel pulls in new dracut with new naming the old kernel will leave
initramfs behind.


To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >