Mailinglist Archive: opensuse-factory (468 mails)

< Previous Next >
[opensuse-factory] MySQL Workbench GRT python2 + libffi8 crash
  • From: Mykola Krachkovsky <w01dnick@xxxxxxxxx>
  • Date: Tue, 07 Apr 2020 13:56:14 +0300
  • Message-id: <1705958.QXrCrHsZ79@thaumaturge>
Hi,

Some time ago libffi was updated from 7 to 8. After that mysql-workbench
stopped to start, I've figured that problem was somewhere in python/ffi code
and
though that rebuild/update to latest would be enough.
For quickfix I've disabled python (`sudo chmod -r /usr/share/mysql-workbench/
libraries/wb.py`).
I've finally updated mysql-workbench version to 8.0.19 in my home OBS
repository, but problem still persists.
Installing libffi7 and running
`LD_PRELOAD=/usr/lib64/libffi.so.7 mysql-workbench`
helps ­— workbench runs without a problem.
But when libffi8 is used I've got exception with backtrace [1].

As my knowledge of Python is very limited, I'd be happy to get some advise.
Is this a python2(-cffi) + libffi8 problem and I should report it?
Is this some mysql-workbench GRT trouble and I should fix it there? And what
exactly?

[1] https://susepaste.org/62613888

--
Kind regards,
Mykola Krachkovsky
--
Найкращі побажання,
Микола Крачковський
< Previous Next >
Follow Ups