Mailinglist Archive: opensuse-factory (468 mails)

< Previous Next >
Re: [opensuse-factory] MultiKey/Compose strangeness after last TW update
On Fri, 3 Apr 2020 12:27:52 +0100, Peter Suetterlin <pit@xxxxxxxxxxx>
wrote:

Hi list,

two days ago I did upgrade my home Tumbleweed machine from 20191216 to
20200325. Since this upgrade, I have issues with the compose key
setup.

I have right Alt defined as MultiKey in .Xmodmap:
keysym Alt_R = Multi_key

An so far could (in any text field) use, e.g., Alt - " - a to get an
umlaut-a. (compose definitions are in .XCompose)

After the upgrade, in Emacs the MultiKey is just completely ignored
and I get "a instead. If I put focus on an XTerm, when pressing the
right Alt key, a weird Icon pops up somewhere on the screen (seems to
be some last-remembered location, so it's not neccessarily in the
same window where focus is). See attached gif (this is 4kB, so I
guess that's OK).

The Compose then does work there, but of course the main place where
I need it is in the editor :(

I tried to figure out what is catching the input and/or where this
behavior is defined (shortcuts etc), but without success.
So any hints where to look are highly appreciated....

It rang a bell, so I did some digging in my chat-logs

26 Feb 2018 I ran into this for the first time (according to my logs)

Feb 26 09:50:03 <[Tux]> something else I found recent: on TW (not on Leap)
Shift-Ctrl-E pops up some Emoji menu. I cannot find the shortcut in
systemsettings5
Feb 26 09:50:38 <[Tux]> and I don't like it, as Shift-Ctrl-E is Extension page
in chrome-based browsers
:
Feb 26 09:58:05 <[Tux]> where Shift-Ctrl-E defined to popup a "Emoji Choice"
menu in plasma5
Feb 26 09:58:37 <[Tux]> as that shortcut overrules the "Go to extensions page"
in chrome-based browsers
:
Feb 26 10:00:17 <fvogt> Let me guess: ibus?
:
Feb 26 10:05:54 <[Tux]> fvogt is correct: /usr/lib64/ibus/ibus-ui-emojier
:
Feb 26 10:10:23 <[Tux]> fvogt: ibus-setup - third tab. I think I need a restart
to have my change effected, but at least the source is found
Feb 26 10:10:26 <[Tux]> thank you
Feb 26 10:13:49 <fvogt> [Tux]: "zypper rm ibus libreoffice-gnome"
Feb 26 11:39:00 <|Tux|> ibus & libreoffice-gnome deleted

and /me was happy again

Then in September (when I did not remember to check my own logs)

Sep 14 10:09:06 <[Tux]> Hello, good * everyone
Sep 14 10:09:45 <[Tux]> I have seen this before, but after my update from 42.3
to 15.0 the key combo Shift_control-E pops up an Emoji chooser
Sep 14 10:10:08 <[Tux]> Where Can I disable that? I cannot find it in
systemsettings5 (running KDE/Plasma)
:
Sep 14 10:16:20 <Mir> ibus
:
Sep 14 10:16:46 <fvogt> That's ibus, yes.
Sep 14 10:17:03 <fvogt> libreoffice pulls that in over gtk3
Sep 14 10:18:45 <[Tux]> $ ibus-setup
Sep 14 10:18:49 <[Tux]> Thank you!
Sep 14 10:19:02 <fvogt> You can also just uninstall it
Sep 14 10:19:21 <fvogt> Ibus is almost as annoying as the windows update
nagging - you can't disable it from autostarting
:
:
Sep 17 14:41:22 <|Tux|> Hi, good afternoon. I have an input-method question
Sep 17 14:42:16 <|Tux|> in perl/Tk applications I can use the Compose key to
generate UTF-8 characters like é, ł, →, ▶,♥ etc etc
Sep 17 14:42:46 <|Tux|> it works fine in xterm, hexchat, perl-Tk, Opera,
Chromium and all on openSUSE 42.3
Sep 17 14:43:51 <|Tux|> but on 15.0 and Tumbleweed it still works in xterm,
hexchat and Opera, but not in perl-Tk
Sep 17 14:44:18 <|Tux|> xterm, hexchat and all of perl were recompiled from
scratch after the update from 42.3 to 15.0
Sep 17 14:44:54 <|Tux|> if this is ibus related, can anyone hint me into how to
get diacriticals and other Compose input to work again?

So it is an old problem that roars its ugly head time after time again

--
H.Merijn Brand http://tux.nl Perl Monger http://amsterdam.pm.org/
using perl5.00307 .. 5.31 porting perl5 on HP-UX, AIX, and Linux
https://useplaintext.email https://tux.nl http://www.test-smoke.org
http://qa.perl.org http://www.goldmark.org/jeff/stupid-disclaimers/
< Previous Next >
Follow Ups
References