Mailinglist Archive: opensuse-factory (355 mails)

< Previous Next >
Solved (was: [opensuse-factory] Re: Changes in gpg-agent / Plasma? SSH-Key no longer available in gpg-agent...)
Hi Neil,

On 12.03.20 at 16:36 Neil Rickert wrote:
On 3/12/20 4:23 AM, Johannes Kastl wrote:

That's your recent change -- using Wayland.

With Wayland, gpg-agent is not automatically started as part of your
desktop startup. Instead, it is started on demand. The effect is
that it cannot share environment variables with your desktop.
Software that uses gpg-agent depends on the socket being in a standard
place. But ssh clients don't know about that.

With X11, gpg-agent is still started as part of session startup.

If you login with Wayland, and then use a gpg command, gpg-agent will
be started at that time. If you now logout, and login with X11, the
left-over gpg-agent will still be running and will block the start of
gpg-agent as part of your X11 session. So maybe try rebooting and
then login to X11 before you conclude that it isn't working there.

Sounds reasonable. And yes, after a reboot it works like before. Thing is, I
thought I had done a reboot after trying Wayland...

Anyway, solved...

Johannes

--
Johannes Kastl
Linux Consultant & Trainer
Tel.: +49 (0) 151 2372 5802
Mail: kastl@xxxxxxxxxxxxx

B1 Systems GmbH
Osterfeldstra├če 7 / 85088 Vohburg
http://www.b1-systems.de
GF: Ralph Dehner
Unternehmenssitz: Vohburg / AG: Ingolstadt,HRB 3537

< Previous Next >