Mailinglist Archive: opensuse-factory (365 mails)

< Previous Next >
Re: [opensuse-factory] OBS Not Publishing Packages?
  • From: Hans-Peter Jansen <hpj@xxxxxxxxx>
  • Date: Fri, 31 Jan 2020 17:14:15 +0100
  • Message-id: <4483757.ddEohNbo75@xrated>
Am Freitag, 31. Januar 2020, 15:21:56 CET schrieb Aleksa Sarai:
I've noticed this a few times over the past couple of days -- certain
packages will have their builds finish but will remain in the "finished"
state rather than becoming "succeeded" (this is especially prevalent for
x86_64 Leap builds). As a result, the packages are built (and you can
see the newest RPMs in the "binaries" page) but the repos aren't
updated.

[1] is an example package where this is happening now (and before I
triggered a rebuild, it was in this state for more than 2 hours). Is
this a known issue?

[1]: https://build.opensuse.org/package/show/Virtualization:containers/lxd

It's an unfortunate behavior of OBS, if it under pressure. Check yourself:

https://build.opensuse.org/monitor

Scroll to the bottom, and check the "Repositories to recalculate" plot: about
2000 repositories with medium priority to recalculate, and even a few hundreds
with high priority ATM.

It usually takes hours to update repositories in this state. Today, this is a
side effect of the OBS cold start for sure. I've seen times, when it took half
a day to update some home repo not too long ago (even *unrelated* to a OBS
cold start).

It's a good idea to enjoy the nice weather (here in the western rhine valley
at least...).

Cheers,
Pete



--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References