Mailinglist Archive: opensuse-factory (428 mails)

< Previous Next >
Re: [opensuse-factory] Moving Firefox to a faster 4-week release cycle - can we get a different name for the ESR release, please?
Hi,

Am 23.09.19 um 15:51 schrieb Hans-Peter Jansen:
Am Sonntag, 22. September 2019, 15:33:50 CEST schrieb Hans-Peter Jansen:
Am Mittwoch, 18. September 2019, 17:15:43 CEST schrieb Wolfgang Rosenauer:
So what could (and probably should) be discussed is if we need a
Factory/TW version of ESR.

Given, that 69.0 regresses in several ways for me here, a firefox-esr
version for Factory is definitely a good idea and worth the hassle.

After reverting to MozillaFirefox-68.1.0 and restoring the related profile┬╣,
both mentioned issues disappeared. I was even able to restore the latest
session from 69.0 in 68.1.0.

Given these facts, I vote for a more conservative FF upgrade approach for TW
generally in the future. I interpret this release cycle change as: let users
beta test it. Interestingly, this move correlates with significant changes in
the developer guild of FF. Mozilla management should check, if the new head
isn't payed from Google already...

Could somebody point me to a forum, where these issues better fit, please.

Cheers,
Pete

┬╣) That's an severe issue for providing both versions. Attempting to use a
downgraded FF with the same profile will *force* the user to create a *new*
profile. I've learned now, that FF remembers the latest version in
compatibility.ini:LastVersion.

as result of this discussion and because I always had these plans but
never enough pressure so far I'm currently preparing a firefox-esr
package which can be installed in parallel to the regular MozillaFirefox
package.
With the new profile handling introduced in Firefox 67 this was finally
not too hard anymore and I seem to have covered almost everything meanwhile.

If people are interested in testing this there are currently builds
running in the mozilla OBS repository.
Once finished you will find a new package
firefox-esr-68.1.0*
there (MozillaFirefox-68.1.0* will disappear) to test also for Leap.

Please note that you most likely need to install
firefox-esr-branding-upstream along because there is no
firefox-esr-branding-openSUSE available yet.
Apart from that and very few modifications missing from the branding
package I'm pretty confident that this will already work to a certain
extent and I'm looking for your feedback.

I still would like to have the regular release as default in Tumbleweed
but this will give people the choice.


Wolfgang
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups