Mailinglist Archive: opensuse-factory (269 mails)

< Previous Next >
Re: [opensuse-factory] Re: [opensuse-factoryTmidity not in shapshot 20190916
On Sun, 22 Sep 2019 18:09:04 +0200,
Jogchum Reitsma wrote:

Op 20-09-19 om 09:47 schreef Takashi Iwai:
On Fri, 20 Sep 2019 08:04:03 +0200,
Jogchum Reitsma wrote:
<...>

BTW, I set up again my test packages in OBS
home:tiwai:branches:multimedia:apps repo. Try to take alsa and
timidity packages (libasound2.rpm and timidity.rpm) from there and
check whether they still show the problem, just to be sure.


thanks,

Takashi

Thanks!

Downloaded and installed libasound2-1.1.9-306.1.x86_64.rpm
<http://download.opensuse.org/repositories/home:/tiwai:/branches:/multimedia:/apps/openSUSE_Tumbleweed/x86_64/libasound2-1.1.9-306.1.x86_64.rpm>
and timidity-2.14.0-322.1.x86_64.rpm
<http://download.opensuse.org/repositories/home:/tiwai:/branches:/multimedia:/apps/openSUSE_Tumbleweed/x86_64/timidity-2.14.0-322.1.x86_64.rpm>
from
http://download.opensuse.org/repositories/home:/tiwai:/branches:/multimedia:/apps/openSUSE_Tumbleweed/x86_64/,
but timidity still segfaults.

To be sure, added alsa-1.1.9-306.1.x86_64.rpm
<http://download.opensuse.org/repositories/home:/tiwai:/branches:/multimedia:/apps/openSUSE_Tumbleweed/x86_64/alsa-1.1.9-306.1.x86_64.rpm>,
but again no difference.

OK, that explains what I totally forgot. In the initial test, I
disabled LTO on both alsa and timidity packages, and it did work.
At the next test, I tried only LTO-disablement on alsa package only,
and this seemed working, but apparently an incorrect test.

So I'm building timidity package again with LTO disablement on my home
repo above. The build for TW is blocked (unresolved) due to
libdevmapper dependency. Once when this is resolved and you get the
new package, please give it a try.


thanks,

Takashi
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups