Mailinglist Archive: opensuse-factory (269 mails)

< Previous Next >
Re: [opensuse-factory] i586 vs. aarch64
On 15/08/2019 10:34, John Paul Adrian Glaubitz wrote:
On 8/15/19 7:48 AM, Peter Czanik wrote:
Here is the bug report sent upstream:
https://lists.gnu.org/archive/html/bug-bison/2019-08/msg00002.html

As far as I could understand (I do not code in C or use bison), the
problem is not architecture specific. It's just a coincidence, that the
problem manifests on i586.
Okay, but then the bug _should_ actually be fixed. If you're just using
"ExcludeArch", you're sweeping the bug under the carpet meaning it can
come back on other architectures which is what I was talking about in
my initial mail in this thread.

In Debian, the bug doesn't seem to be known [1]. Maybe it manifests in
certain build environments only.

Building syslog-ng on s390 also seems to be affected:

https://build.opensuse.org/build/home:czanik:branches:Base:System/openSUSE_Factory_zSystems/s390x/syslog-ng/_log

Should I ExcludeArch that as well for now?

And there is a mixed situation on FreeBSD: there is lots of garbage on
screen while compiling syslog-ng on FreeBSD 12.0 / AMD64, but it still
compiles and works fine.

The proposed fix was sent upstream by my colleague who debugged the
problem I reported originally against syslog-ng:
https://github.com/balabit/syslog-ng/issues/2861#issuecomment-518769524
But I'm not aware of a new bison release containing the fix.

Bye,

CzP


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages