Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
[opensuse-factory] Leap 15.2 Build 490.1 released!
  • From: Ludwig Nussel <ludwig.nussel@xxxxxxx>
  • Date: Fri, 30 Aug 2019 13:12:20 +0000
  • Message-id: <156717074060.11905.10628835398551773874@go-agent-stagingbot-9>

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&version=15.2&build=490.1&groupid=50
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Distribution&query_format=advanced&resolution=---&version=Leap%2015.2

When you reply to discuss some issues, make sure to change the subject.
Please use the test plan at
https://docs.google.com/spreadsheets/d/1AGKijKpKiJCB616-bHVoNQuhWHpQLHPWCb3m1p6gXPc/edit#gid=94909276
to record your testing efforts and use bugzilla to report bugs.

Packages changed:
aaa_base
ebtables
kernel-source (4.12.14 -> 5.3.rc5)
yast2-auth-client (4.2.1 -> 4.2.2)
yast2-auth-server (4.2.2 -> 4.2.3)
yast2-configuration-management (4.2.1 -> 4.2.2)
yast2-iscsi-client (4.2.1 -> 4.2.2)
yast2-kdump (4.2.1 -> 4.2.2)
yast2-pam (4.2.3 -> 4.2.4)
yast2-proxy (4.2.1 -> 4.2.2)
yast2-security (4.2.0 -> 4.2.1)
yast2-services-manager (4.2.0 -> 4.2.3)
yast2-theme (4.2.4 -> 4.2.5)
yast2-vpn (4.2.1 -> 4.2.2)

=== Details ===

==== aaa_base ====
Subpackages: aaa_base-extras aaa_base-malloccheck

- Add patch git-06-8640f848c6677f1149b9765a8c86135956604007.patch
* Make systemd detection cgroup oblivious (bsc#1140647)
systemd can work in three exclusive cgroup modes: legacy, hybrid and
unified. The mode affects where and what cgroup hierarchies are mounted.
detect running systemd as systemd itself does it
(src/libsystemd/sd-daemon/sd-daemon.c, function sd_booted)

==== ebtables ====

- fix path (/sbin -> /usr/sbin) in ebtables.systemd [bsc#1140898]

==== kernel-source ====
Version update (4.12.14 -> 5.3.rc5)

- update branch metadata
- fix OBS build project (15.1 -> 15.2)
- set BUGZILLA_PRODUCT to "openSUSE Distribution"
- commit faed656
- config: import configs from master branch
Copy Tumbleweed configs from master branch, adjust CONFIG_SUSE_* options
for openSUSE Leap 15.2 and refresh the configs with gcc 7.4.
- commit 5a5dbd7
- update branch metadata
- update README.BRANCH text
- update build project in rpm/config.sh
- commit 6408d97
- config: restore correct PHYSICAL_START and PHYSICAL_ALIGN on x86_64
These were already fixed in master by kernel-source commit baa2434a5ab6 but
old (and wrong) values were restored by merge of SLE15-SP1 config. Fix them
also in SLE15-SP2 now.
- commit 9b6f95a
- config: update from SLE15-SP2
In general, we want features and drivers from SLE also in openSUSE unless
we have a good reason not to. Enable most config options which were
disabled in master but enabled in SLE15-SP2 (inherited from SLE15-SP1).
- commit 769684a
- series.conf: reorganize sections
With ~40 patches in master branch, we have accumulated way too many
sections in series.conf, some of them being very specific. While new SLE
and Leap branches are going to have more patches, vast majority of them is
going to end up in the sorted section (e.g. less than 1% of SLE15-SP1
patches are neither sorted nor stable baskports right now - and that
includes quite a few which would actually belong into the sorted section
but are left outside for historical reasons).
After the reorganization, series.conf is ordered like this:
- stable backports (patches.kernel.org/*)
- tweaks applied to vanilla (patches.rpmify/*)
- sorted section (not in master)
- unsorted patches expected to get into mainline soon
- permanent and longterm non-upstream patches
- kabi hacks (not in master)
This commit has no effect on expanded tree.
- commit 8ac1895
- series.conf: cleanup
Only whitespace and comments, no efect on expanded tree.
- commit bf21808
- config: import SLE15-SP1 configs
Replace configs inherited from master branch by proper SLE ones. With few
obvious exceptions, the initial SLE15-SP2 configs were created using these
rules (for each option, use first rule which applies):
- use value explicitly changed with reference to a feature or a bug
- use value from SLE15-SP1 if the option exists there
- use value from master if the option exists there
- use upstream default
The configs will need review by people responsible for specific kernel
subsystems and architectures.
Also update supported.conf with new modules:
- add intel_pmc_core_pltdrv as unsupported
- fix cfb{copyarea,fillrect,imgblt} path and mark "+base" as virtio-gpu
depends on them
- commit dded633
- Update config files.
As per https://jira.suse.com/browse/SLE-7041
Factory first!
- commit 126cef1
- Update README.BRANCH
- drop Jeff Mahoney (inherited from master)
- add Miroslav Benes as comaintainer
- drop misleading paragraph left from master branch
- commit 4300e4e
- Update to 5.3-rc5
- Refresh configs
- RDMA_SIW available on i386 (=m)
- clean up unavailable options
- commit cadbe00
- config: arm64: Enable I2C_IMX (boo#1146026)
Needed for Google Coral board.
- commit 8803b04
- Revert "Workaround gcc regression on ppc64 (bko#204125)."
This reverts commit 8b84d1d46ff90146bb6ba5b760a54ddd87a1a680.
Works for me 5.3-rc4-65-g329120423947
- commit d8f9e6c
- config.conf: syms should not depend on kernel-zfcpdump
Kernel-zfcpdump is not modular so kernel-zfcpdump-devel does not make
sense and is not built. kernel-syms cannot depend on it.
- commit 473ac28
- rpm/mkspec: Correct tarball URL for rc kernels.
- commit c4ef18d
- config: refresh with gcc7
Unlike master branch, SLE15-SP2 is supposed to be built with gcc7. At
the moment, this only makes a significant difference on aarch64 (which
we already refreshed with gcc 7.4.0 for this reason) but let's refresh
all configs to make it more visible.
- commit 67e1879
- Update to 5.3-rc4
- Refresh
-
patches.suse/kernel-add-product-identifying-information-to-kernel-build.patch
- commit 5402233
- rpm/config.sh: Enable building DTBs.
- commit 7de292a
- rpm/mkspec: Make building DTBs optional.
- commit 7c057c8
- supported.conf: fix supported modules depending on unsupported on non-x86_64
architectures
Some more "unsupported module needed by supported one" errors were reported
on aarch64 and ppc64le.
- commit 6b609de
- supported.conf: drop obsolete entry for hyperv_fb
The module moved to a different directory, the obsolete entry causes
file conflict betwen kernel-default and kernel-default-extra.
- commit 6b112e5
- rpm/modflist: Simplify compression support.
- commit fd135a6
- supported.conf: close with respect to dependencies
Modules which some supported module depends on must be supported as well.
Also drop obsolete entries for rtsx_pci and rtsx_usb which were moved
between 4.12 and 5.3.
- commit b781c36
- rpm: support compressed modules
Some of our scripts and scriptlets in rpm/ do not expect module files not
ending with ".ko" which currently leads to failure in preuninstall
scriptlet of cluster-md-kmp-default (and probably also other subpackages).
Let those which could be run on compressed module files recognize ".ko.xz"
in addition to ".ko".
- commit 18fcdff
- Bring back MODVERDIR to Makefile.modpost (bsc#1066369).
- commit 6cc69f5
- supported.conf: sort again
Make the order compatible with scripts/supported-conf-fixup (LC_ALL=C).
- commit 4a4b5dd
- supported.conf: Sort alphabetically, align comments.
- commit 5189766
- series.conf: cleanup
Move patches.suse/0001-oracleasm-4.0-compat-changes.patch
to more appropriate place.
- commit 2080902
- supported.conf: drop extensions
To make things more consistent, drop all ".ko" extensions.
- commit 398461b
- Update patches.suse/supported-flag.
Fix ReST table.
- commit 0692bf4
- Use upstream TAINT_AUX for TAINT_EXTERNAL_SUPPORT.
Refresh patches.suse/supported-flag.
- commit a4999e0
- rpm/kernel-obs-build.spec.in: add dm-crypt for building with cryptsetup
Co-Authored-By: Adam Spiers <aspiers@xxxxxxxx>
- commit 1756301
- rpm/kernel-binary.spec.in: Enable supported.conf check.
- commit 96adf4d
- Update arm64 config files.
- commit 1e7a157
- supported.conf: add missing entries for all architectures
As list of built modules depends on architecture, we must also add entries
for modules which are not built (or do not even exist) on x86_64 but are
built on other architectures (aarch64, ppc64le, s390x).
- commit 8f74082
- supported.conf: add missing entries
Add all modules currently built but not listed in supported.conf.
Another update will be necessary once we replace configs inherited from
master with true SLE15-SP2 configs. This is also why entries for modules
not built are left in the file for now.
- commit 0f5033c
- supported.conf: sort
Also remove one commented out line.
- commit b539157
- supported.conf: cleanup
Remove duplicate and shadowed entries.
- commit 25e91ec
- supported.conf: update from SLE15-SP1
Differences from current SLE15-SP1 supported.conf:
- f71808e_wdt and it87_wdt supported (jdelvare)
- bpfilter marked +base (tiwai, bsc#1106751)
- unified indentation
- commit 02162e4

==== yast2-auth-client ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-auth-server ====
Version update (4.2.2 -> 4.2.3)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.3

==== yast2-configuration-management ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-iscsi-client ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-kdump ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-pam ====
Version update (4.2.3 -> 4.2.4)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.4

==== yast2-proxy ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2

==== yast2-security ====
Version update (4.2.0 -> 4.2.1)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.1

==== yast2-services-manager ====
Version update (4.2.0 -> 4.2.3)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.3

==== yast2-theme ====
Version update (4.2.4 -> 4.2.5)
Subpackages: yast2-theme-breeze yast2-theme-oxygen

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.5

==== yast2-vpn ====
Version update (4.2.1 -> 4.2.2)

- Using rb_default_ruby_abi tag in the spec file in order to
handle several ruby versions (bsc#1146403).
- 4.2.2


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups