Mailinglist Archive: opensuse-factory (439 mails)

< Previous Next >
[opensuse-factory] Leap 15.1 Build 449.2 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&version=15.1&build=449.2&groupid=50
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Distribution&query_format=advanced&resolution=---&version=Leap%2015.1

When you reply to discuss some issues, make sure to change the subject.
Please use the test plan at
https://docs.google.com/spreadsheets/d/1AGKijKpKiJCB616-bHVoNQuhWHpQLHPWCb3m1p6gXPc/edit#gid=94909276
to record your testing efforts and use bugzilla to report bugs.

Packages changed:
NetworkManager
apache2
apparmor
desktop-translations (84.87.20190314.58da68e1 -> 84.87.20190409.048e157e)
glibc
glibc
kdebase4-workspace
kwin5
libzypp (17.11.3 -> 17.11.4)
mariadb-connector-c
osinfo-db (20181116 -> 20190301)
python-rpm-macros (2017.12.22.d9968ab -> 20190402.c88be49)
webkit2gtk3 (2.22.6 -> 2.24.0)
wget
wicked (0.6.53 -> 0.6.54)
yast2-samba-client (4.1.1 -> 4.1.2)
zchunk (1.0.3 -> 1.1.0)

=== Details ===

==== NetworkManager ====
Subpackages: NetworkManager-lang libnm-glib-vpn1 libnm-glib4 libnm-util2 libnm0
typelib-1_0-NM-1_0 typelib-1_0-NMClient-1_0 typelib-1_0-NetworkManager-1_0

- Add NetworkManager-make-nm-wait-online-follow-nm-service.patch:
make enablement of n-m-wait-online.service follow n-m.service
(boo#1130355).

==== apache2 ====
Subpackages: apache2-doc apache2-example-pages apache2-prefork apache2-utils

- security update
- added patches
CVE-2019-0211 [bsc#1131233]
+ apache2-CVE-2019-0211.patch (thanks to Simotek)
CVE-2019-0220 [bsc#1131241]
+ apache2-CVE-2019-0220.patch
CVE-2019-0217 [bsc#1131239]
+ apache2-CVE-2019-0217.patch
CVE-2019-0197 [bsc#1131245], CVE-2019-0196 [bsc#1131237]
+ apache2-mod_http2-1.14.1.patch

==== apparmor ====
Subpackages: apparmor-abstractions apparmor-docs apparmor-parser
apparmor-parser-lang apparmor-profiles apparmor-utils apparmor-utils-lang
perl-apparmor python3-apparmor

- dovecot-align-pop3-managesieve-login-to-imap-login.patch
allow network access and notify file creation/access
(bsc#1120279)
- identd-include-proc-tcp.patch: add /proc/pid/tcp readable (bsc#1125439)

==== desktop-translations ====
Version update (84.87.20190314.58da68e1 -> 84.87.20190409.048e157e)

- Update to version 84.87.20190409.048e157e:
* Translated using Weblate (Arabic)
* Translated using Weblate (German)
* Translated using Weblate (Italian)
* Translated using Weblate (Polish)
* Translated using Weblate (Slovak)
* Translated using Weblate (Spanish)

==== glibc ====

- japanese-era-name-may-2019.patch: ja_JP locale: Add entry for the new
Japanese era (bsc#1100396, BZ #22964)

==== glibc ====
Subpackages: glibc-extra glibc-locale glibc-locale-base nscd

- japanese-era-name-may-2019.patch: ja_JP locale: Add entry for the new
Japanese era (bsc#1100396, BZ #22964)

==== kdebase4-workspace ====

- Remove the last %kde4_pimlibs_requires line.
Nothing should require kdepimlibs4 anymore.
- Remove gpsd-devel BuildRequires, not only it breaks with latest
gpsd, but it is also completely unused (Plasma 4.x is no longer
present in any supported openSUSE version)

==== kwin5 ====
Subpackages: kwin5-lang

- Add patch to decrease CPU usage with the prop. nvidia driver:
* 0001-platforms-x11-Force-glXSwapBuffers-to-block-with-NVI.patch

==== libzypp ====
Version update (17.11.3 -> 17.11.4)

- Enhance scanning /sys for modaliases (bsc#1130161)
- version 17.11.4 (9)
- Prevent SEGV if the application sets an empty TextLocale (bsc#1127026)
- Fix build with CMake >= 3.14.0:
Starting with CMake 3.14, EXCLUDE_FROM_ALL now spreads from
directories to targets. 'make -C someSubdir' when 'someSubdir'
uses the 'EXCLUDE_FROM_ALL' keyword does nothing. (gh/libzypp#libzypp#165)

==== mariadb-connector-c ====

- move libmariadb.pc from /usr/lib/pkgconfig to
/usr/lib64/pkgconfig [bsc#1126088]

==== osinfo-db ====
Version update (20181116 -> 20190301)

- Add support for Caasp40 media
add-caasp40-support.patch
- Update database to version 20190301
osinfo-db-20190301.tar.xz
- Update database to version 20190120
osinfo-db-20190120.tar.xz

==== python-rpm-macros ====
Version update (2017.12.22.d9968ab -> 20190402.c88be49)

- Update to version 20190402.c88be49:
* Add missing $ expansion on the pytest call
- Update to version 20190315.d3034bf bsc#1128323:
* Rewrite pytest and pytest_arch into Lua macros with multiple arguments.
- Update to version 20190307.81ca329:
* We should preserve existing PYTHONPATH.
- bsc#1128323: Update to version 20190307.fbaed33
* Add --ignore to pytest calls to ignore build directories.
- Update to version 20190221.08f1194:
* Actually make pytest into function to capture arguments as well
* Add pytest definitions.
- Use upstream-recommended %{_rpmconfigdir}/macros.d directory
for the rpm macros.
- Include license and readme.
- Update to version 20181211.ab6f37c:
* Fix an issue with epoch printing having too many \
* Remove packaging/ dir
- Update to version 1540475376.149a499:
* add epoch while printing "Provides:"
- Update URL
- Add _service and use the tar_scm/recompress/set_version source
services to update the package.
Package updates can now be done with "osc service run"
- Drop README.packaging
- Drop update.sh . This is now handled via the source services
- version bump to 2018.08.15.ada6d63

==== webkit2gtk3 ====
Version update (2.22.6 -> 2.24.0)
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
libwebkit2gtk3-lang typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Add webkitgtk-gstreamer-gl-build-fix.patch: fix build on
SLE/Leap 15 (webkit#196178).
- Update to version 2.24.0:
+ Added support fot content filtering.
+ Variation fonts support.
+ Fully emoji rendering support.
+ Added navigation and pinch zoom gestures for touchpads.
+ Support for JPEG2000 images.
+ Script dialogs are now modal to the current web view only.
+ New API to convert URI to format for display.
+ Security fixes: CVE-2019-8375 (boo#1126768).
- Add openjpeg2 and openjpeg2-devel BuildRequires on SLE 15: New
dependencies.
- Drop webkit2gtk3-python3.patch: Not needed anymore.
- Stop passing -DENABLE_ACCELERATED_2D_CANVAS=ON to cmake, follow
upstream default.

==== wget ====

- Fixed a buffer overflow vulnerability
[bsc#1131493, CVE-2019-5953,
wget-buffer-overflow-CVE-2019-5953.patch]

==== wicked ====
Version update (0.6.53 -> 0.6.54)
Subpackages: libwicked-0-6 wicked-service

- version 0.6.54
- switch to use systemd notify and prevent event backlog at start
by calling udevadm settle before starting wickedd (bsc#1118206)
- dhcp6: don't discard confirm reply without status (bsc#1127340)
- ethtool: set lro legacy flag and not txvlan (bsc#1123555)
- init memory before use in ioctl
- fsm: fix find pending worker loop segfault (boo#1106809)

==== yast2-samba-client ====
Version update (4.1.1 -> 4.1.2)

- Fix join fails with 'Failed to join domain: Invalid configuration';
(bsc#1131607).
- 4.1.2

==== zchunk ====
Version update (1.0.3 -> 1.1.0)

- Update to version 1.1.0
+ Fix multipart boundary bug when dealing with lighttpd servers
+ Optimize chunk matching while downloading, significantly reducing CPU usage


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages