Mailinglist Archive: opensuse-factory (439 mails)

< Previous Next >
Re: [opensuse-factory] KDE4/Qt4 removal from openSUSE Factory
Am Montag, 1. April 2019, 12:08:27 schrieb Christophe Giboudeaux:
- SoQt, used by FreeCAD-test (what's that?) and python-pivy
That's FreeCAD's test suite, but FreeCAD itself uses Qt5 since some time...

- gnucash, looks like an indirect dependency, the Qt4 support was already
removed
Probably coming from gwenhywfar-devel, which still has the Qt4 backend (or is
it frontend?) enabled. Was needed by kmymoney 4.x, but that's Qt5/KF5 based
since a while anyway.

Unfortunately they replaced gwenhyfar with a recent beta in the devel project,
which would break aqbanking and also kmymoney and gnucash (aqbanking could be
updated too but that still would break kmymoney at least, no idea about
gnucash), so it seems currently not possible to update the package in Factory
to disable that... :-/

- taglib-extras
The libkde4-devel BuildRequires can probably just be removed in this case.
The only reference to KDE in the build log:
[ 91s] CMake Warning:
[ 91s] Manually-specified variables were not used by the project:
[ 91s]
[ 91s] BUILD_TESTS
[ 91s] WITH_KDE

And the libtag-extras1 package installed on my Leap 15.0 system doesn't have
any dependency on libkde4/libqt4 either...

- testdisk, last release is from 2015
That's likely just the qphotorec application though.
I don't think the textmode tools would need it... ;-) (and it's probably
better not to drop them IMHO)

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >