Mailinglist Archive: opensuse-factory (401 mails)

< Previous Next >
Re: [opensuse-factory] Don't upgrade to a 5.0.x Kernel with a Dell Precision 5530


On 3/18/19 5:51 PM, Dan Čermák wrote:
Dan Čermák <dcermak@xxxxxxxx> writes:

Marco Varlese <marco.varlese@xxxxxxxx> writes:

On 3/18/19 4:10 PM, Dan Cermak wrote:


Felix Miata <mrmazda@xxxxxxxxxxxxx> 03/18/19 3:55 PM >>>
Dan Cermak composed on 2019-03-18 15:11 (UTC+0100):

Nope, I have blacklisted everything from Nvidia & Nouveau, so only the
Intel driver should be running.

Actually it likely shouldn't. Intel pays its Linux driver writers to put
most of
their effort into the FOSS modesetting DDX driver. The xf86-video-intel
DDX is in
maintenance mode, having had no official release since 2015.

Sorry, wrong wording: there are only Intel kernel modules loaded and no
Nvidia/Nouveau kernel modules.

Also, I tried the Tumbleweed rescue disk: that one will start booting,
but at some point the laptop screen just turns off and that's it.

Exactly how did you "blacklist" nouveau? Do it wrong, and you might block
all DDX drivers.


Like this:

$ cat /etc/modprobe.d/99-blacklist-nvidia.conf
blacklist nouveau
blacklist nvidia
blacklist nvidia_drm
blacklist nvidia_modeset



Precision 5530 is a model line, not a model. Which do you have? Better
yet, what
is output from 'inxi -Gxx' (which reports both kernel and DDX drivers,
among other
useful video info if X is running)? What does cat /proc/cmdline report?
Xorg.0.log?

inxi -Gxx reports:

Graphics: Device-1: Intel UHD Graphics 630 vendor: Dell driver: N/A bus
ID: 00:02.0 chip ID: 8086:3e9b
Device-2: NVIDIA GP107GLM [Quadro P1000 Mobile] vendor: Dell driver: N/A
bus ID: 01:00.0 chip ID: 10de:1cbb
Display: tty server: X.org 1.20.4 driver: N/A tty: 227x82
Message: Advanced graphics data unavailable in console. Try -G --display

/proc/cmdline:

BOOT_IMAGE=/boot/vmlinuz-5.0.2-2.gd1f1d19-default
root=/dev/mapper/system-root splash=silent resume=/dev/system/swap quiet
mem_sleep_default=deep nomodeset

I have added the nomodeset parameter myself as Larry recomended, that gets
me to at least to a tty.

There is no Xorg.0.log, as I don't automatically start X on boot. However
when launching it with nomodeset added, startx fails with not being able
to load the i915.ko kernel module.

That's interesting...

Ok, at least this mystery is solved: I removed xf86-video-intel and
now X is starting again (haven't tried with nomodeset though, I am
currently on a custom 4.20 where nomodeset is not required).
I don't have that at all on my system which is running kernel 5.x...

Maybe, try to simply blacklist that and restart your machine with the
5.x kernel...?



I did update and I also have the Intel card which requires the i915
kernel module. It all works seamlessly. :/

Might be some differences in the actual CPU model?


Do you see anything in the "dmesg" when trying to load the kernel module
itself?

mvarlese@localhost:~> sudo lsmod |grep i915
i915 2158592 28
i2c_algo_bit 16384 1 i915
drm_kms_helper 204800 5 i915
drm 499712 16 drm_kms_helper,i915
video 49152 3 dell_wmi,dell_laptop,i915

mine looks like this:
Boreas:~ # lsmod |grep i915
i915 2158592 0
i2c_algo_bit 16384 1 i915
drm_kms_helper 204800 1 i915
drm 499712 2 drm_kms_helper,i915
video 49152 3 dell_wmi,dell_laptop,i915

So not sure why X is even trying to load the kernel module at all?

There is nothing in the log, because Xorg is started as an unprivileged
user and thus cannot load kernel modules.

Nevertheless, I am not sure if this is the right track, as I only got
this far because I appended 'nomodeset' to the boot command line. Maybe
it is messing with the driver?

mvarlese@localhost:~> uname -a
Linux localhost.localdomain 5.0.1-1-default #1 SMP Mon Mar 11 06:36:03
UTC 2019 (8c6a826) x86_64 x86_64 x86_64 GNU/Linux





--
Marco Varlese | Architect Developer Technologies
SUSE LINUX GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg) Maxfeldstr. 5, D-90409, Nürnberg

< Previous Next >