Mailinglist Archive: opensuse-factory (401 mails)

< Previous Next >
Re: [opensuse-factory] python-pygit2 broken


On 07/03/2019 10:14, Martin Wilck wrote:
The python-pygit2 package in TW is broken in multiple ways -
it depends on the no-longer-existent libgit2-27, and on an obsolete
version of python-cffi. I believe the latter problem is only a
consequence of failing builds because of the missing libgit2-devel
0.27.0. AFAICS, upstream pygit2 has not announced support for libgit2
0.28.0.

Anyway - is there a solution on the horizon, or a known workaround
other than locking python-pygit2 for the time being?

Well given that [1] doesn't list any "Bugowners" the package is not currently maintained so unless it magically fixes itself and starts building again it will likely be dropped in the not too distant future. if its a package that you and or your team still care about, you or someone should request bugownership and maintainership in the devel repo and start looking after the package, unless your really lucky and find someone else who's willing to.


1. https://build.opensuse.org/package/users/devel:languages:python/python-pygit2

--

Simon Lees (Simotek) http://simotek.net

Emergency Update Team keybase.io/simotek
SUSE Linux Adelaide Australia, UTC+10:30
GPG Fingerprint: 5B87 DB9D 88DC F606 E489 CEC5 0922 C246 02F0 014B
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References