Mailinglist Archive: opensuse-factory (401 mails)

< Previous Next >
[opensuse-factory] Leap 15.1 Build 423.1 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&version=15.1&build=423.1&groupid=50
https://bugzilla.opensuse.org/buglist.cgi?product=openSUSE%20Distribution&query_format=advanced&resolution=---&version=Leap%2015.1

When you reply to discuss some issues, make sure to change the subject.
Please use the test plan at
https://docs.google.com/spreadsheets/d/1AGKijKpKiJCB616-bHVoNQuhWHpQLHPWCb3m1p6gXPc/edit#gid=94909276
to record your testing efforts and use bugzilla to report bugs.

Packages changed:
apache2
autoyast2 (4.1.1 -> 4.1.2)
libkgapi
libqt5-qtspeech
libstorage-ng (4.1.91 -> 4.1.93)
qemu
yast2-bootloader (4.1.17 -> 4.1.18)
yast2-storage-ng (4.1.66 -> 4.1.67)

=== Details ===

==== apache2 ====
Subpackages: apache2-doc apache2-example-pages apache2-prefork apache2-utils

- security update
* CVE-2018-17189 [bsc#1122838]
+ apache2-mod_http2-1.11.4.patch
* CVE-2018-17199 [bsc#1122839]
+ apache2-CVE-2018-17199.patch
- do not create sysconfig.d when already exists [bsc#1121086]

==== autoyast2 ====
Version update (4.1.1 -> 4.1.2)
Subpackages: autoyast2-installation

- Avoid to crash when the profile has a not valid sofware section
(bsc#1125959).
- 4.1.2

==== libkgapi ====
Subpackages: libKPimGAPICalendar5 libKPimGAPIContacts5 libKPimGAPICore5
libKPimGAPITasks5 libkgapi-lang sasl2-kdexoauth2

- Add Contacts-fix-email-type-deserialization.patch to fix broken
email fields in google contacts (boo#1126614, kde#398847)
- Use < %{version} again for obsoleting sasl2-kdexoauth2-3

==== libqt5-qtspeech ====

- Add packageand(speech-dispatcher:%{libname}) supplements to the speechd plugin
- Add the plugin to baselibs.conf

==== libstorage-ng ====
Version update (4.1.91 -> 4.1.93)
Subpackages: libstorage-ng-lang libstorage-ng-ruby libstorage-ng1

- merge gh#openSUSE/libstorage-ng#618
- updated pot and po files
- 4.1.93
- merge gh#openSUSE/libstorage-ng#617
- extended parser for lvs command
- added function to join Texts
- added unit tests
- use callback to report unsupported logical volumes (bsc#1099744)
- coding style
- allow to ignore errors during in probe utility
- consistent message style
- added function to join names of block devices
- improved messages for creating volume groups and mds
- consistent naming style
- use new join function in message about deleting filesystems
- fixed typo
- 4.1.92

==== qemu ====
Subpackages: qemu-block-curl qemu-block-rbd qemu-block-ssh qemu-guest-agent
qemu-ipxe qemu-ksm qemu-seabios qemu-sgabios qemu-tools qemu-ui-curses
qemu-ui-gtk qemu-ui-sdl qemu-vgabios qemu-x86

- Package and cross-build rom files for aarch64 from
SLE15/Leap15.0 to fix boo#1125964
- Add patch to fix seabios cross-compilation:
* seabios-fix_cross_compilation.patch
- Add patch to fix sgabios cross-compilation:
* sgabios-fix-cross-build.patch
- Fix _constraints to include all architectures for disk size
(fix aarch64)

==== yast2-bootloader ====
Version update (4.1.17 -> 4.1.18)

- Relax check for bios_boot when logical device over more disks is
used to check that at least one disk can be bootable.
(bsc#1125792)
- Also relax installation of grub2. When at least one location
success then do not complain, just log it.
- 4.1.18

==== yast2-storage-ng ====
Version update (4.1.66 -> 4.1.67)

- Partitioner: improve "Import Mount Points" feature.
Now, a fstab entry cannot be imported when the filesystem type
is not supported. Moreover, the "mount by" type is assigned
according to the fstab entry and the label of the previous
filesystem is preserved (bsc#1103391).
- 4.1.67


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages