Mailinglist Archive: opensuse-factory (602 mails)

< Previous Next >
Re: [opensuse-factory] Dependencies for Perl not resolvable (libgdbm.so.5)
W dniu 13.02.2019 o 12:44, Dominique Leuenberger / DimStar pisze:
On Wed, 2019-02-13 at 12:13 +0100, Dominique Leuenberger / DimStar
wrote:
On Wed, 2019-02-13 at 12:04 +0100, John Paul Adrian Glaubitz wrote:
Hi!

I'm trying to build updated Python packages in my home project in d:l:p:aws
which fails with:

unresolvable: nothing provides libgdbm.so.5()(64bit) needed by perl

Is there a gdbm transition going on at the moment?

gdbm has been updated to 1.18, resulting in libgdbm.so.6 - and
libgdbm.so.5 disappearing. In order to make the bootstrap cycle not
blow over, a libgdbm5 compat package was added to Factory, which was
not meant to be published - but the pure presence of this package made
our scripts not realize that perl needed to be rebuilt against the new
version of gdbm :(

And some fun issues bled through repos. I'm busy trying to fix the
issue.

A hack should be in place that should solve this issue for now. Can you
please verify and confirm if your issue vanished?

Cheers
Dominique


Thanks for fighting this bug.

Unfortunately my packages are also affected and still blocked
example:
https://build.opensuse.org/package/show/home:etamPL:branches:network:cryptocurrencies/ethereum-cpp

Adam Mizerski

< Previous Next >