Mailinglist Archive: opensuse-factory (602 mails)

< Previous Next >
Re: [opensuse-factory] Can't upgrade TW due to borgmatic wanting Python 3.6
On 05 Feb 13:06, İsmail Dönmez wrote:
Hi,
On 05 Feb 12:45, Michael Pujos wrote:
sudo zypper dup --no-allow-vendor-change
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
2 Problems:
Problem: python3-pykwalify-1.6.0-2.1.noarch requires python(abi) = 3.6, but
this requirement cannot be provided
Problem: borgmatic-1.2.14-1.1.noarch requires python(abi) = 3.6, but this
requirement cannot be provided

Problem: python3-pykwalify-1.6.0-2.1.noarch requires python(abi) = 3.6, but
this requirement cannot be provided
  deleted providers: python3-base-3.6.5-3.3.x86_64
 Solution 1: deinstallation of python3-pykwalify-1.6.0-2.1.noarch
 Solution 2: keep obsolete python3-base-3.6.5-3.3.x86_64
 Solution 3: break python3-pykwalify-1.6.0-2.1.noarch by ignoring some of
its dependencies




What should I do ?

It's a long list of dependency issues, which in reality comes down to
ipywidgets
being not compatible with python 3.7, which
https://build.opensuse.org/request/show/671831 should workaround borgbackup
case.

s/borgbackup/borgmatic

ismail

--
SUSE Linux GmbH, GF: Felix Imendörffer, Jane Smithard, Graham Norton,
HRB 21284 (AG Nürnberg)
< Previous Next >