Mailinglist Archive: opensuse-factory (602 mails)

< Previous Next >
Re: [opensuse-factory] dozens of unwanted packages !


On 02/02/2019 11:34, Daniele wrote:
Il 02/02/19 01:31, Karl Cheng ha scritto:
On Sat, 2 Feb 2019 at 11:12, Daniele <kailed@xxxxxxxxxx> wrote:
Please, stop adding craps like xeyes, xload & company.
Who do I have to kill? Package/pattern I mean ;)

qantas94heavy@linux-abc3:~> zypper se --recommends xload
Loading repository data...
Reading installed packages...

S | Name     | Summary                                                
| Type
--+----------+---------------------------------------------------------+--------

   | xorg-x11 | Compatibility metapackage for X.Org sample
applications | package


Oh thanks.  Next question is who requires/recommends xorg-x11 ?

# zypper se --recommends xorg-x11
Loading repository data...
Reading installed packages...

S  | Name                             | Summary                     | Type
---+----------------------------------+------------------------------------------------------+--------

i+ | mkfontdir                        | Utility to create index of X
font files              | package
i+ | mkfontscale                      | Utility to create index of
scalable font files for X | package
i+ | patterns-base-x11                | X Window System
                    | package
   | patterns-base-x11-32bit          | X Window System
                     | package
 l | patterns-base-x11_enhanced       | X Window System
                     | package
   | patterns-base-x11_enhanced-32bit | X Window System
                     | package
   | patterns-base-x11_opt            | X Window System
                     | package
i+ | patterns-fonts-fonts             | Fonts                     | package
i+ | patterns-fonts-fonts_opt         | Fonts                     | package
   | patterns-lxde-lxde               | LXDE Desktop Environment
                     | package
   | patterns-lxqt-lxqt               | LXQt Desktop Environment
                     | package
   | patterns-media-rest_dvd          | Remaining Software
                     | package
   | patterns-server-kvm_tools        | KVM Virtualization Host and
tools                    | package
   | patterns-server-xen_tools        | XEN Virtualization Host and
tools                    | package
   | python2-PyVirtualDisplay         | Python wrapper for Xvfb, Xephyr
and Xvnc             | package
   | python2-pytest-xvfb              | Pytest plugin to run Xvfb for
tests                  | package
   | python3-PyVirtualDisplay         | Python wrapper for Xvfb, Xephyr
and Xvnc             | package
   | python3-pytest-xvfb              | Pytest plugin to run Xvfb for
tests                  | package
   | sway                             | Window manager for Wayland
compatible with i3        | package
   | xorg-x11-Xvnc                    | TigerVNC implementation of Xvnc
                     | package
i+ | xorg-x11-server                  | X                     | package
   | xorg-x11-server-extra            | Additional Xservers (Xdmx,
Xephyr, Xnest)            | package
i+ | xorg-x11-server-wayland          | Xwayland Xserver
                    | package

Is this list correct ?
It seems that, for example, patterns-fonts-fonts does not require
xorg-x11. Also all already installed packages and patterns are installed
for a long time. So, why it happens now ?

Thanks,
Daniele.



Yeah I can't see why it thinks patterns-fonts-fonts should pull it in
unless you have a really old version. At some point in the next week or
so i'm going to do another iteration of patterns-base changes, I think
its reasonable that patterns-base-x11 just requires xorg-x11-essentials
and not all of xorg-x11 so i'll fix that then.


--

Simon Lees (Simotek) http://simotek.net

Emergency Update Team keybase.io/simotek
SUSE Linux Adelaide Australia, UTC+10:30
GPG Fingerprint: 5B87 DB9D 88DC F606 E489 CEC5 0922 C246 02F0 014B

< Previous Next >