Mailinglist Archive: opensuse-factory (453 mails)

< Previous Next >
Re: [opensuse-factory] New Tumbleweed snapshot 20190201 released!
  • From: Axel Braun <axel.braun@xxxxxx>
  • Date: Sun, 03 Feb 2019 16:47:04 +0100
  • Message-id: <3192855.d3eSaZ2si0@t520.axxite.internal>
Am Sonntag, 3. Februar 2019, 16:12:07 CET schrieb Stephan Kulow:
- it updates python from 3.6 to 3.7 and bash from 4.4 to 5.0
and both changes were far from painless

Yes, I stumbled over one:
Problem: python3-fastnumbers-2.1.1-1.1.x86_64 benötigt python(abi) = 3.6, kann
jedoch nicht zur Verfügung gestellt werden

The package fails in testing part:

[ 76s] ___________________ ERROR collecting tests/test_builtins.py
____________________
[ 76s] ImportError while importing test module '/home/abuild/rpmbuild/BUILD/
fastnumbers-2.1.1/tests/test_builtins.py'.
[ 76s] Hint: make sure your test modules/packages have valid Python names.
[ 76s] Traceback:
[ 76s] tests/test_builtins.py:20: in <module>
[ 76s] from builtin_tests.py37.builtin_test_float import *
[ 76s] tests/builtin_tests/py37/builtin_test_float.py:10: in <module>
[ 76s] from test import support
[ 76s] /usr/lib64/python3.7/_import_failed/test.py:22: in <module>
[ 76s] to install it.""".format(failed_name, package))
[ 76s] E ImportError: Module 'test' is not installed.
[ 76s] E Use:
[ 76s] E sudo zypper install python3-testsuite
[ 76s] E to install it.

Interesting hint, as there is no python-testsuite in OBS.....

Cheers
Axel



--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >