Mailinglist Archive: opensuse-factory (633 mails)

< Previous Next >
Re: [opensuse-factory] Yast (and some console programs) not correctly displaying
  • From: "Wolfgang Bauer" <wbauer@xxxxxx>
  • Date: Sat, 19 Jan 2019 09:36:58 +0100
  • Message-id: <!&!AAAAAAAAAAAYAAAAAAAAADokrqXjCOpBs583LEuAEsWCgQAAEAAAAHc9oo+Ks0xHti7NjYSmM7cBAAAAAA==@tmo.at>
Am Freitag, 18. Jan 2019, 16:24:46 schrieb Joachim Wagner:
And now I execute again 'yast' (so this is again the textmode version).
Here is are link to screenshots of what I get now (same windows of yast):
www.hantsch.co.at/_temp/Snap138.jpg
www.hantsch.co.at/_temp/Snap139.jpg (A sub-module)

The problem on these screenshots doesn't look like it's related to the
locale at all.
It's likely rather this I think:
https://bugzilla.opensuse.org/1054448
https://bugzilla.opensuse.org/1056020
https://bugs.kde.org/384620

In short, recent ncurses versions use the RPT control sequence to repeat
characters when $TERM is set to "xterm".
But older konsole versions didn't support that.

As a workaround, set TERM to e.g. "konsole" or "linux", you can change that
in konsole's profile settings or manually with "export TERM=xxx".
Or use xterm, which supports RPT since something like 20 years...

If you're inclined to, it should be easy to backport the fix to older
konsole versions too:
https://phabricator.kde.org/D10064

Kind Regards,
Wolfgang


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups