Mailinglist Archive: opensuse-factory (188 mails)

< Previous Next >
Re: [opensuse-factory] Snapshot 20181214 QT library incompatibilities
Am Mittwoch, 19. Dezember 2018, 22:16:59 schrieb Ben Holmes:
Wolfgang Bauer writes:
> libqt5-qtscxml hasn't been updated to 5.12.0 in Factory yet, the
> submission is still pending:
> https://build.opensuse.org/request/show/656567
>
> And 5.11.2 fails to build against Qt 5.12...
>
> Do you actually need that?

I 'sort of' do, since it is a dependency for qxmledit. I use qxmledit a
bit for work, but I don't need it right now. I could probably uninstall
it for a while, but I think I will just wait.

Ok, I mainly asked because if you wouldn't, you could uninstall it and the
update would probably succeed...

I did an update and kept all obsolete conflicting packages. I am now
running the new Mesa framework, but it is tearing and flickering a bit.
I think it is a good time to roll back!

Just in case it is helpful before I roll back (I noticed other people
having similar issues in another thread)...

Well, that might not be related to Qt at all then, maybe the Mesa update
caused this.

As I wrote in the other thread, you may try to disable compositing as a
workaround, or maybe switch to XRender.

Although, I see that the other poster fixed it by uninstalling xf86-video-
intel and therefore use the "modesettings" driver instead.

Thanks, and have a fantastic Christmas!

Thank you, I wish you that as well! ;-)

Am Mittwoch, 19. Dezember 2018, 04:29:03 schrieb Chuck Davis:
I didn't get any error messages during the update but the 12/14 update
rendered my desktop useless.

The former applies to you as well, I suppose.

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References