Mailinglist Archive: opensuse-factory (188 mails)

< Previous Next >
Re: [opensuse-factory] Snapshot 20181214 QT library incompatibilities
  • From: Chuck Davis <cjgunzel@xxxxxxxxx>
  • Date: Wed, 19 Dec 2018 04:29:03 -0800
  • Message-id: <CAHf=Y_ZGgerGQh6YWZB91f48DdOKQF3R8AYaeyJR5_k5pSCuxQ@mail.gmail.com>
I didn't get any error messages during the update but the 12/14 update
rendered my desktop useless.


On Wed, Dec 19, 2018 at 4:17 AM Ben Holmes <osuse_mail@xxxxxxxxxxxx> wrote:

Wolfgang Bauer writes:
> I suppose that's the main problem here:
> Am Mittwoch, 19. Dezember 2018, 17:22:48 schrieb Ben Holmes:
>> Problem: libQt5Scxml5-5.11.2-1.1.x86_64 requires
>> libQt5Qml.so.5(Qt_5.11.2_PRIVATE_API)(64bit), but this requirement
>> cannot be provided
>
> libqt5-qtscxml hasn't been updated to 5.12.0 in Factory yet, the
> submission is still pending:
> https://build.opensuse.org/request/show/656567
>
> And 5.11.2 fails to build against Qt 5.12...
>
> Do you actually need that?

I 'sort of' do, since it is a dependency for qxmledit. I use qxmledit a
bit for work, but I don't need it right now. I could probably uninstall
it for a while, but I think I will just wait.

> In general they are binary compatible, but that's not necessarily
true > for the private API (that's why it's called private).

I did notice that it was the private API, and I was trying to update
'part' of my set of QT libraries.

>> Is it safe to ignore the dependencies?
>
> No.

I was hoping wishful thinking would prevail...

Patience is a virtue here. I should not have, but I still did an update
of sorts.

I did an update and kept all obsolete conflicting packages. I am now
running the new Mesa framework, but it is tearing and flickering a bit.
I think it is a good time to roll back!

Just in case it is helpful before I roll back (I noticed other people
having similar issues in another thread)...

System: Host: bh-lenlap Kernel: 4.19.7-1-default x86_64 bits: 64
compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4
tk: Qt 5.11.2 wm: kwin_x11 dm: SDDM Distro: openSUSE
Tumbleweed 20181214
Graphics: Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:5917
Display: x11 server: X.org 1.20.3 driver: modesetting
unloaded: fbdev,vesa alternate: intel compositor: kwin_x11
resolution: <xdpyinfo missing>
OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake
GT2) v: 4.5 Mesa 18.3.1 compat-v: 3.0
direct render: Yes

> Kind Regards,
> Wolfgang

Thanks, and have a fantastic Christmas!
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References