Mailinglist Archive: opensuse-factory (188 mails)

< Previous Next >
Re: [opensuse-factory] Snapshot 20181214 QT library incompatibilities
  • From: Mykola Krachkovsky <w01dnick@xxxxxxxxx>
  • Date: Wed, 19 Dec 2018 11:47:42 +0200
  • Message-id: <2333959.rNQ3rqv6hX@thaumaturge>
середа, 19 грудня 2018 р. 09:22:48 EET Ben Holmes написано:
G'day Tumblers,

When updating to 20181214, I get the following errors:

... skipped ...

Is this happening for everyone, or is it just me?
Nope, not just you. Some Qt libraries (base part) already updated to 5.12 and
some (less common) weren't updated neither rebuilt.
That happens not the first time [1], I prefer just to wait for all libraries to
update/rebuild and then update distro.


Is it safe to ignore the dependencies?
Might be not safe to, as mentioned libs were built with different version of
private Qt API, while it could (not *should*) be compatible at source level
there could be differences in binary.

[1] https://lists.opensuse.org/opensuse-factory/2017-10/msg00625.html

--
Kind regards,
Mykola Krachkovsky
--
Найкращі побажання,
Микола Крачковський
< Previous Next >
References