Mailinglist Archive: opensuse-factory (381 mails)

< Previous Next >
Re: [opensuse-factory] NVidia Bumblebee driver update, question for i586 users
On 10/23/18 3:29 PM, Mykola Krachkovsky wrote:
i586 and x86_64/32bit are separate packages.
i586 are for 32-bit systems: means 32-bit kernel module, 32-bit X module and
32-bit client libraries. Last versions are 390.xx for this.
x86_64/32bit are for 32-bit apps on 64-bit system, so it contains just 32-bit
client libraries (located in installer's directory "32"). Kernel module and X
module are still 64-bit and installed from x86_64 package.
So in i586 repository we have only 390 version while in x86_64 we have 410
for
both x86_64 and x86_64/32bit packages.

You should still be able to create an i586 package for 32-bit systems running on
a 64-bit kernel. It seems that Debian is now doing exactly that [1].

This way, you can still use the latest drivers on a 32-bit system provided your
machine is running a 64-bit kernel. As you said, nVidia just stopped developing
32-bit kernel code, all the 32-bit userland code is still there and in
development.

Adrian

[1]
https://buildd.debian.org/status/package.php?p=nvidia-graphics-drivers&suite=experimental
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >