Mailinglist Archive: opensuse-factory (381 mails)

< Previous Next >
Re: [opensuse-factory] A look on RPM compression in openSUSE
On Saturday 2018-10-13 19:38, cagsm wrote:

One thing comes up my mind from past incidents while suse upgrades.
Dont forget about to-be-upgraded systems when changing essential stuff
such as compression compatibility an opensuse version some years ago,
that had a show stopper that caused incompatibility in the rpm packages
while zypper dup-ing or something similar, which made it necessary to
use an updated rpm and or some related libs first before being able to
perform a zypper dup.

Well, once you start thinking, you will recognize that this situation -
requiring an updated rpm - is inevitable: A sufficiently old rpm program
just is not going to be able to read a sufficiently new rpm package.
That is to say, even if rpm has had feature X for time Y, some dude will
try to upgrade from a version older than Y.
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References